mirror of https://github.com/openwrt/packages.git
libmraa: fix compilation with GCC10
Taken from an upstream issue. Signed-off-by: Rosen Penev <rosenp@gmail.com>pull/15033/head
parent
6331dc62d5
commit
07d0ee7552
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=libmraa
|
||||
PKG_VERSION:=2.2.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/eclipse/mraa/tar.gz/v$(PKG_VERSION)?
|
||||
|
|
|
@ -0,0 +1,13 @@
|
|||
--- a/include/version.h
|
||||
+++ b/include/version.h
|
||||
@@ -11,8 +11,8 @@
|
||||
extern "C" {
|
||||
#endif
|
||||
|
||||
-const char* gVERSION;
|
||||
-const char* gVERSION_SHORT;
|
||||
+extern const char* gVERSION;
|
||||
+extern const char* gVERSION_SHORT;
|
||||
|
||||
#ifdef __cplusplus
|
||||
}
|
Loading…
Reference in New Issue