atlas-probe: fix compilation with GCC14

Missing header.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
pull/25265/head^2
Rosen Penev 2024-10-29 21:43:22 -07:00
parent f2d5c861bd
commit 0b0841e290
2 changed files with 11 additions and 1 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=atlas-probe
PKG_VERSION:=2.6.3
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=$(PKG_VERSION)

View File

@ -0,0 +1,10 @@
--- a/networking/telnetd.c
+++ b/networking/telnetd.c
@@ -133,6 +133,7 @@
#include <string.h>
#include <unistd.h>
#include <linux/reboot.h>
+#include <sys/reboot.h>
#define LOGIN_PREFIX "Atlas probe, see http://atlas.ripe.net/\r\n\r\n"
#define LOGIN_PROMPT " login: "