mirror of https://github.com/openwrt/packages.git
libx264: update to 2024-01-13 revision
- Fix CPU type detection to enable asm on ARM - Refresh patches Signed-off-by: krant <aleksey.vasilenko@gmail.com>pull/23349/head
parent
3fbfef7081
commit
0bdec78a8b
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=x264
|
||||
PKG_VERSION:=2020-10-26
|
||||
PKG_VERSION:=2024-01-13
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://code.videolan.org/videolan/x264.git
|
||||
PKG_SOURCE_VERSION:=4121277b40a667665d4eea1726aefdc55d12d110
|
||||
PKG_MIRROR_HASH:=4b4955e8f92d0c4afecbced2cc6414a123085f7472d198b3eeddaa9490b84f60
|
||||
PKG_SOURCE_VERSION:=4815ccadb1890572f2bf8b9d9553d56f6c9122ad
|
||||
PKG_MIRROR_HASH:=6a8179183bdd88f2d7032342c23670e66571724ad774f96a6abac19f8eb7aad4
|
||||
|
||||
PKG_MAINTAINER:=Adrian Panella <ianchi74@outlook.com>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
@ -31,16 +31,16 @@ MAKE_FLAGS:=$(filter-out LD=%,$(MAKE_FLAGS)) LD="$(TARGET_CC) -o"
|
|||
# Instead of blacklisting a boatload of platforms just enable
|
||||
# optimization where it makes sense (matters) ie ARMv7+ and x86_64
|
||||
|
||||
ifneq ($(findstring cortex-a,$(CPU_TYPE)),)
|
||||
ifneq ($(findstring cortex-a,$(CONFIG_CPU_TYPE)),)
|
||||
CONFIGURE_ARGS += --enable-lto
|
||||
else
|
||||
else
|
||||
ifneq ($(CONFIG_TARGET_x86_64),)
|
||||
CONFIGURE_ARGS += --enable-lto
|
||||
ifeq ($(CONFIG_NASM),y)
|
||||
CONFIGURE_VARS+= AS=nasm
|
||||
MAKE_FLAGS+= AS=nasm
|
||||
endif
|
||||
else
|
||||
else
|
||||
CONFIGURE_VARS+= AS=
|
||||
MAKE_FLAGS+= AS=
|
||||
CONFIGURE_ARGS += --disable-asm
|
||||
|
|
|
@ -18,7 +18,7 @@ Signed-off-by: Christopher Larson <chris_larson@mentor.com>
|
|||
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -769,7 +769,13 @@ case $host_cpu in
|
||||
@@ -771,7 +771,13 @@ case $host_cpu in
|
||||
AS_EXT=".asm"
|
||||
ASFLAGS="$ASFLAGS -DARCH_X86_64=1 -I\$(SRCPATH)/common/x86/"
|
||||
stack_alignment=16
|
||||
|
@ -33,7 +33,7 @@ Signed-off-by: Christopher Larson <chris_larson@mentor.com>
|
|||
if [ "$SYS" = MACOSX ]; then
|
||||
ASFLAGS="$ASFLAGS -f macho64 -DPREFIX"
|
||||
if cc_check '' "-arch x86_64"; then
|
||||
@@ -788,7 +794,11 @@ case $host_cpu in
|
||||
@@ -790,7 +796,11 @@ case $host_cpu in
|
||||
RCFLAGS="--target=pe-x86-64 $RCFLAGS"
|
||||
fi
|
||||
else
|
||||
|
|
|
@ -16,7 +16,7 @@ Signed-off-by: Maxin B. John <maxin.john@intel.com>
|
|||
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -975,9 +975,6 @@ if [ $asm = auto -a \( $ARCH = X86 -o $A
|
||||
@@ -988,9 +988,6 @@ if [ $asm = auto -a \( $ARCH = X86 -o $A
|
||||
fi
|
||||
|
||||
if [ $asm = auto -a $ARCH = ARM ] ; then
|
||||
|
|
Loading…
Reference in New Issue