mirror of https://github.com/openwrt/packages.git
i2pd: Update to 2.38.0
Remove USE_AVX and USE_AESNI make options as it is correclty handled by internal code. Signed-off-by: R4SAS I2P <r4sas@i2pmail.org>pull/15703/head
parent
2e02d899ae
commit
1025dd7c76
|
@ -9,12 +9,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=i2pd
|
PKG_NAME:=i2pd
|
||||||
PKG_VERSION:=2.36.0
|
PKG_VERSION:=2.38.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/PurpleI2P/i2pd/tar.gz/$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/PurpleI2P/i2pd/tar.gz/$(PKG_VERSION)?
|
||||||
PKG_HASH:=17b7309cbee41b991cf9480334495c5a049f709beb1b31fbfcb47de19c8462a3
|
PKG_HASH:=8452f5323795a1846d554096c08fffe5ac35897867b93a5079605df8f80a3089
|
||||||
|
|
||||||
PKG_MAINTAINER:=David Yang <mmyangfl@gmail.com>
|
PKG_MAINTAINER:=David Yang <mmyangfl@gmail.com>
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
|
@ -55,7 +55,6 @@ define Build/Prepare
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_LDFLAGS+=-latomic
|
TARGET_LDFLAGS+=-latomic
|
||||||
MAKE_FLAGS+=USE_AESNI=no USE_AVX=no
|
|
||||||
|
|
||||||
define Package/i2pd/install
|
define Package/i2pd/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
|
|
|
@ -15,7 +15,7 @@
|
||||||
|
|
||||||
## Where to write pidfile (default: i2pd.pid, not used in Windows)
|
## Where to write pidfile (default: i2pd.pid, not used in Windows)
|
||||||
# pidfile = /run/i2pd.pid
|
# pidfile = /run/i2pd.pid
|
||||||
@@ -25,12 +25,12 @@
|
@@ -26,12 +26,12 @@
|
||||||
## * stdout - print log entries to stdout
|
## * stdout - print log entries to stdout
|
||||||
## * file - log entries to a file
|
## * file - log entries to a file
|
||||||
## * syslog - use syslog, see man 3 syslog
|
## * syslog - use syslog, see man 3 syslog
|
||||||
|
@ -30,16 +30,7 @@
|
||||||
## Write full CLF-formatted date and time to log (default: write only time)
|
## Write full CLF-formatted date and time to log (default: write only time)
|
||||||
# logclftime = true
|
# logclftime = true
|
||||||
|
|
||||||
@@ -61,7 +61,7 @@ ipv6 = false
|
@@ -84,7 +84,7 @@ ipv6 = false
|
||||||
# ifname6 =
|
|
||||||
|
|
||||||
## Enable NTCP transport (default = true)
|
|
||||||
-# ntcp = true
|
|
||||||
+ntcp = false
|
|
||||||
## If you run i2pd behind a proxy server, you can only use NTCP transport with ntcpproxy option
|
|
||||||
## Should be http://address:port or socks://address:port
|
|
||||||
# ntcpproxy = http://127.0.0.1:8118
|
|
||||||
@@ -81,7 +81,7 @@ ipv6 = false
|
|
||||||
|
|
||||||
## Router will not accept transit tunnels, disabling transit traffic completely
|
## Router will not accept transit tunnels, disabling transit traffic completely
|
||||||
## (default = false)
|
## (default = false)
|
||||||
|
@ -47,8 +38,8 @@
|
||||||
+notransit = true
|
+notransit = true
|
||||||
|
|
||||||
## Router will be floodfill
|
## Router will be floodfill
|
||||||
# floodfill = true
|
## Note: that mode uses much more network connections and CPU!
|
||||||
@@ -91,8 +91,10 @@ ipv6 = false
|
@@ -95,8 +95,10 @@ ipv6 = false
|
||||||
## Uncomment and set to 'false' to disable Web Console
|
## Uncomment and set to 'false' to disable Web Console
|
||||||
# enabled = true
|
# enabled = true
|
||||||
## Address and port service will listen on
|
## Address and port service will listen on
|
||||||
|
@ -59,8 +50,8 @@
|
||||||
+# strictheaders = false
|
+# strictheaders = false
|
||||||
## Path to web console, default "/"
|
## Path to web console, default "/"
|
||||||
# webroot = /
|
# webroot = /
|
||||||
## Uncomment following lines to enable Web Console authentication
|
## Uncomment following lines to enable Web Console authentication
|
||||||
@@ -104,7 +106,7 @@ port = 7070
|
@@ -108,7 +110,7 @@ port = 7070
|
||||||
## Uncomment and set to 'false' to disable HTTP Proxy
|
## Uncomment and set to 'false' to disable HTTP Proxy
|
||||||
# enabled = true
|
# enabled = true
|
||||||
## Address and port service will listen on
|
## Address and port service will listen on
|
||||||
|
@ -69,7 +60,7 @@
|
||||||
port = 4444
|
port = 4444
|
||||||
## Optional keys file for proxy local destination
|
## Optional keys file for proxy local destination
|
||||||
# keys = http-proxy-keys.dat
|
# keys = http-proxy-keys.dat
|
||||||
@@ -118,7 +120,7 @@ port = 4444
|
@@ -122,7 +124,7 @@ port = 4444
|
||||||
## Uncomment and set to 'false' to disable SOCKS Proxy
|
## Uncomment and set to 'false' to disable SOCKS Proxy
|
||||||
# enabled = true
|
# enabled = true
|
||||||
## Address and port service will listen on
|
## Address and port service will listen on
|
||||||
|
@ -78,12 +69,14 @@
|
||||||
port = 4447
|
port = 4447
|
||||||
## Optional keys file for proxy local destination
|
## Optional keys file for proxy local destination
|
||||||
# keys = socks-proxy-keys.dat
|
# keys = socks-proxy-keys.dat
|
||||||
@@ -228,7 +230,8 @@ verify = true
|
@@ -237,9 +239,9 @@ verify = true
|
||||||
|
|
||||||
[persist]
|
[persist]
|
||||||
## Save peer profiles on disk (default: true)
|
## Save peer profiles on disk (default: true)
|
||||||
-# profiles = true
|
-# profiles = true
|
||||||
+profiles = false
|
+profiles = false
|
||||||
|
## Save full addresses on disk (default: true)
|
||||||
|
-# addressbook = true
|
||||||
+addressbook = false
|
+addressbook = false
|
||||||
|
|
||||||
[cpuext]
|
[cpuext]
|
||||||
|
|
Loading…
Reference in New Issue