mirror of https://github.com/openwrt/packages.git
lxc: update to 4.10.12
Bump to latest upstream release and rebase: 010-Remove-distro-check.patch 025-remove-unsupported-option.patch After updating ran `make package/lxc/refresh` to clean dirty patches Build system: x86_64 Build-tested: bcm2711/RPi4B Run-tested: bcm2711/RPi4B Signed-off-by: John Audia <graysky@archlinux.us>pull/17824/head
parent
7a46dfb05d
commit
115bf07f6c
|
@ -9,12 +9,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lxc
|
||||
PKG_VERSION:=4.0.10
|
||||
PKG_VERSION:=4.0.12
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://linuxcontainers.org/downloads/lxc/
|
||||
PKG_HASH:=a10c518056d2e497bd600e4ffac2853bdeab1e835bf455a6d87cc8df128bfae9
|
||||
PKG_HASH:=db242f8366fc63e8c7588bb2017b354173cf3c4b20abc18780debdc48b14d3ef
|
||||
|
||||
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
|
||||
PKG_LICENSE:=LGPL-2.1-or-later BSD-2-Clause GPL-2.0
|
||||
|
|
|
@ -5,12 +5,9 @@ Subject: [PATCH] Remove distro check
|
|||
|
||||
Signed-off-by: Robert Marko <robert.marko@sartura.hr>
|
||||
---
|
||||
configure.ac | 28 ----------------------------
|
||||
1 file changed, 28 deletions(-)
|
||||
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -78,34 +78,6 @@ esac
|
||||
@@ -79,34 +79,6 @@ esac
|
||||
LT_INIT
|
||||
AC_SUBST([LIBTOOL_DEPS])
|
||||
|
||||
|
@ -19,7 +16,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
|
|||
-AC_MSG_CHECKING([host distribution])
|
||||
-AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO], [Specify the Linux distribution to target: One of redhat, redhatenterpriseserver, oracle, centos, fedora, suse, gentoo, debian, arch, slackware, plamo, paldo, openmandriva, pardus, sparclinux, altlinux.]))
|
||||
-if type lsb_release >/dev/null 2>&1 && test "z$with_distro" = "z"; then
|
||||
- with_distro=`lsb_release -is`
|
||||
- with_distro=$(lsb_release -is)
|
||||
-fi
|
||||
-if test "z$with_distro" = "z"; then
|
||||
- AC_CHECK_FILE(/etc/redhat-release,with_distro="redhat")
|
||||
|
@ -40,7 +37,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
|
|||
- AC_CHECK_FILE(/etc/altlinux-release,with_distro="altlinux")
|
||||
- AC_CHECK_FILE(/etc/pld-release,with_distro="pld")
|
||||
-fi
|
||||
-with_distro=`echo ${with_distro} | tr '[[:upper:]]' '[[:lower:]]'`
|
||||
-with_distro=$(echo ${with_distro} | tr '[[:upper:]]' '[[:lower:]]')
|
||||
-
|
||||
if test "z$with_distro" = "zforsparc"; then
|
||||
with_distro="sparclinux"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/templates/lxc-download.in
|
||||
+++ b/templates/lxc-download.in
|
||||
@@ -512,20 +512,7 @@ fi
|
||||
@@ -384,20 +384,7 @@ fi
|
||||
# Unpack the rootfs
|
||||
echo "Unpacking the rootfs"
|
||||
|
||||
|
|
Loading…
Reference in New Issue