mirror of https://github.com/openwrt/packages.git
tang: tang-show-keys uses wget instead of curl
Resolves: #15592 Signed-off-by: Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>pull/21964/head
parent
3e38742aab
commit
148b1b2d5e
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=tang
|
||||
PKG_VERSION:=14
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://github.com/latchset/$(PKG_NAME)/releases/download/v$(PKG_VERSION)/
|
||||
|
|
|
@ -0,0 +1,13 @@
|
|||
diff --git a/src/tang-show-keys b/src/tang-show-keys
|
||||
index 0c33c3a..f017e84 100755
|
||||
--- a/src/tang-show-keys
|
||||
+++ b/src/tang-show-keys
|
||||
@@ -27,7 +27,7 @@ fi
|
||||
|
||||
port=${1-80}
|
||||
|
||||
-adv=$(curl -sSf "localhost:$port/adv")
|
||||
+adv=$(wget -qO- "http://127.0.0.1:$port/adv")
|
||||
|
||||
THP_DEFAULT_HASH=S256 # SHA-256.
|
||||
jose fmt --json "${adv}" -g payload -y -o- \
|
Loading…
Reference in New Issue