mirror of https://github.com/openwrt/packages.git
acl: update to 2.3.2
Signed-off-by: Maxim Storchak <m.storchak@gmail.com>pull/23349/head
parent
1d50a9bb4e
commit
1803ec3732
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=acl
|
||||
PKG_VERSION:=2.3.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.3.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://git.savannah.nongnu.org/cgit/acl.git/snapshot
|
||||
PKG_HASH:=8cad1182cc5703c3e8bf7a220fc267f146246f088d1ba5dd72d8b02736deedcc
|
||||
PKG_HASH:=0fc318808c1e91925398cbe41399a33b74dcf788a1c0af4feae8f7a322c6e6fd
|
||||
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
|
||||
|
||||
PKG_LICENSE:=LGPL-2.1 GPL-2.0
|
||||
|
|
|
@ -1,16 +1,19 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -33,9 +33,6 @@ AC_SYS_LARGEFILE
|
||||
@@ -34,12 +34,6 @@ AC_SYS_LARGEFILE
|
||||
AM_PROG_AR
|
||||
LT_INIT
|
||||
|
||||
-AM_GNU_GETTEXT_VERSION([0.18.2])
|
||||
-dnl Minimal version supporting AM_GNU_GETTEXT_REQUIRE_VERSION.
|
||||
-AM_GNU_GETTEXT_VERSION([0.19.6])
|
||||
-dnl Require at least the following version, but use the latest available one.
|
||||
-AM_GNU_GETTEXT_REQUIRE_VERSION([0.19.8])
|
||||
-AM_GNU_GETTEXT([external])
|
||||
-
|
||||
AC_ARG_ENABLE([debug],
|
||||
[AS_HELP_STRING([--enable-debug], [Enable extra debugging])])
|
||||
AS_IF([test "x$enable_debug" = "xyes"],
|
||||
@@ -67,6 +64,5 @@ AC_CONFIG_COMMANDS([include/sys],
|
||||
@@ -69,6 +63,5 @@ AC_CONFIG_COMMANDS([include/sys],
|
||||
AC_CONFIG_FILES([
|
||||
libacl.pc
|
||||
Makefile
|
||||
|
|
|
@ -1,7 +1,9 @@
|
|||
--- a/autogen.sh
|
||||
+++ b/autogen.sh
|
||||
@@ -1,4 +1,2 @@
|
||||
@@ -1,6 +1,4 @@
|
||||
#!/bin/sh -ex
|
||||
-po/update-potfiles
|
||||
-autopoint --force
|
||||
am_libdir=$(automake --print-libdir)
|
||||
cp "${am_libdir}/INSTALL" doc/
|
||||
exec autoreconf -f -i
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
From 2b42f64737adf6a2ddd491213580d6e9cdd2f5af Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Thu, 10 Nov 2022 18:04:15 -0800
|
||||
Subject: [PATCH] chacl: Use portable version of dirent and readdir
|
||||
|
||||
Using 64bit versions on 32bit architectures should be enabled with
|
||||
--enable-largefile, this makes it portable across musl and glibc
|
||||
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
---
|
||||
tools/chacl.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/tools/chacl.c
|
||||
+++ b/tools/chacl.c
|
||||
@@ -320,7 +320,7 @@ walk_dir(acl_t acl, acl_t dacl, const ch
|
||||
{
|
||||
int failed = 0;
|
||||
DIR *dir;
|
||||
- struct dirent64 *d;
|
||||
+ struct dirent *d;
|
||||
char *name;
|
||||
|
||||
if ((dir = opendir(fname)) == NULL) {
|
||||
@@ -332,7 +332,7 @@ walk_dir(acl_t acl, acl_t dacl, const ch
|
||||
return(0); /* got a file, not an error */
|
||||
}
|
||||
|
||||
- while ((d = readdir64(dir)) != NULL) {
|
||||
+ while ((d = readdir(dir)) != NULL) {
|
||||
/* skip "." and ".." entries */
|
||||
if (strcmp(d->d_name, ".") == 0 || strcmp(d->d_name, "..") == 0)
|
||||
continue;
|
Loading…
Reference in New Issue