mirror of https://github.com/openwrt/packages.git
gitlab-runner: Update to 16.0.2
* Added test.sh script * Fixed build with riscv64 * Passed package version via go ldflags * Refreshed patches * Removed useless test binaries from package Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>pull/21366/head
parent
b53a83815f
commit
27b4291bd4
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gitlab-runner
|
||||
PKG_VERSION:=14.3.2
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=16.0.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v$(PKG_VERSION)
|
||||
PKG_HASH:=f67aeae05349f5c612ea5d8772407237caf4da586c0365e3c7edceec6b853d8c
|
||||
PKG_HASH:=f874b9babe21ae04007abfc901e9ad4c0c1ec22095d4de3e22e176914683cb5d
|
||||
|
||||
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
|
||||
PKG_LICENSE:=MIT
|
||||
|
@ -23,7 +23,9 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/gitlab-runner-v$(PKG_VERSION)
|
|||
PKG_BUILD_DEPENDS:=golang/host
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_BUILD_FLAGS:=no-mips16
|
||||
|
||||
GO_PKG:=gitlab.com/gitlab-org/gitlab-runner
|
||||
GO_PKG_LDFLAGS_X:=$(GO_PKG)/common.VERSION=$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../lang/golang/golang-package.mk
|
||||
|
@ -41,5 +43,12 @@ define Package/gitlab-runner/description
|
|||
GitLab CI/CD to run jobs in a pipeline.
|
||||
endef
|
||||
|
||||
define Package/gitlab-runner/install
|
||||
$(call GoPackage/Package/Install/Bin,$(PKG_INSTALL_DIR))
|
||||
$(INSTALL_DIR) $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gitlab-runner $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gitlab-runner-helper $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call GoBinPackage,gitlab-runner))
|
||||
$(eval $(call BuildPackage,gitlab-runner))
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/common/buildtest/masking.go
|
||||
+++ b/common/buildtest/masking.go
|
||||
@@ -45,7 +45,7 @@ func RunBuildWithMasking(t *testing.T, c
|
||||
@@ -55,7 +55,7 @@ func RunBuildWithMasking(t *testing.T, c
|
||||
|
||||
buf.Finish()
|
||||
|
||||
|
|
|
@ -0,0 +1,3 @@
|
|||
#!/bin/sh
|
||||
|
||||
gitlab-runner --version | grep "$PKG_VERSION"
|
Loading…
Reference in New Issue