mirror of https://github.com/openwrt/packages.git
linuxptp: fix bad formats with ppc64 and mips64
Signed-off-by: Rosen Penev <rosenp@gmail.com>pull/17736/head
parent
6cfc4baf41
commit
31a8112c51
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=linuxptp
|
||||
PKG_VERSION:=3.1.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/v$(PKG_VERSION)
|
||||
|
|
|
@ -0,0 +1,12 @@
|
|||
--- a/ts2phc_slave.c
|
||||
+++ b/ts2phc_slave.c
|
||||
@@ -4,6 +4,9 @@
|
||||
* @note Copyright (C) 2019 Balint Ferencz <fernya@sch.bme.hu>
|
||||
* @note SPDX-License-Identifier: GPL-2.0+
|
||||
*/
|
||||
+#ifndef __SANE_USERSPACE_TYPES__
|
||||
+#define __SANE_USERSPACE_TYPES__ /* For PPC64, to get LL64 types */
|
||||
+#endif
|
||||
#include <errno.h>
|
||||
#include <linux/ptp_clock.h>
|
||||
#include <poll.h>
|
Loading…
Reference in New Issue