mirror of https://github.com/openwrt/packages.git
parent
62267be558
commit
37be5e57bc
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=icu4c
|
||||
PKG_VERSION:=59.1
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=60.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-59_1-src.tgz
|
||||
PKG_SOURCE:=$(PKG_NAME)-60_1-src.tgz
|
||||
PKG_SOURCE_URL:=http://download.icu-project.org/files/$(PKG_NAME)/$(PKG_VERSION)
|
||||
PKG_HASH:=7132fdaf9379429d004005217f10e00b7d2319d0fea22bdfddef8991c45b75fe
|
||||
PKG_HASH:=f8f5a6c8fbf32c015a467972bdb1477dc5f5d5dfea908b6ed218715eeb5ee225
|
||||
|
||||
PKG_LICENSE:=ICU-1.8.1+
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
|
|
@ -2,7 +2,7 @@ diff --git a/Makefile.in b/Makefile.in
|
|||
index 9db6c52..6aa2273 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -184,7 +184,6 @@ install-icu: $(INSTALLED_BUILT_FILES)
|
||||
@@ -186,7 +186,6 @@ install-icu: $(INSTALLED_BUILT_FILES)
|
||||
$(INSTALL_SCRIPT) $(top_srcdir)/install-sh $(DESTDIR)$(pkgdatadir)/install-sh
|
||||
@$(MKINSTALLDIRS) $(DESTDIR)$(libdir)/pkgconfig
|
||||
$(INSTALL_DATA) $(ALL_PKGCONFIG_FILES) $(DESTDIR)$(libdir)/pkgconfig/
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -883,8 +883,8 @@
|
||||
AC_CHECK_FUNC(strtod_l)
|
||||
if test x$ac_cv_func_strtod_l = xyes
|
||||
then
|
||||
- CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=1"
|
||||
- U_HAVE_STRTOD_L=1
|
||||
+ CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=0"
|
||||
+ U_HAVE_STRTOD_L=0
|
||||
else
|
||||
CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=0"
|
||||
U_HAVE_STRTOD_L=0
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -7093,8 +7093,8 @@
|
||||
|
||||
if test x$ac_cv_func_strtod_l = xyes
|
||||
then
|
||||
- CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=1"
|
||||
- U_HAVE_STRTOD_L=1
|
||||
+ CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=0"
|
||||
+ U_HAVE_STRTOD_L=0
|
||||
else
|
||||
CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=0"
|
||||
U_HAVE_STRTOD_L=0
|
|
@ -1,10 +0,0 @@
|
|||
Index: source/i18n/zonemeta.cpp
|
||||
===================================================================
|
||||
--- source/i18n/zonemeta.cpp (revision 40283)
|
||||
+++ source/i18n/zonemeta.cpp (revision 40324)
|
||||
@@ -691,5 +691,4 @@
|
||||
if (U_FAILURE(status)) {
|
||||
delete mzMappings;
|
||||
- deleteOlsonToMetaMappingEntry(entry);
|
||||
uprv_free(entry);
|
||||
break;
|
Loading…
Reference in New Issue