attr: fix compilation with GCC 14

Missing header.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
pull/24124/head
Rosen Penev 2024-05-12 20:43:11 -07:00
parent 6a007dcabb
commit 39dad4ff47
2 changed files with 11 additions and 1 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=attr
PKG_VERSION:=2.5.2
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://git.savannah.nongnu.org/cgit/attr.git/snapshot

View File

@ -0,0 +1,10 @@
--- a/tools/attr.c
+++ b/tools/attr.c
@@ -27,6 +27,7 @@
#include <unistd.h>
#include <errno.h>
#include <string.h>
+#include <libgen.h>
#include <locale.h>
#include <attr/attributes.h>