mirror of https://github.com/openwrt/packages.git
libcap: Fix compilation with uClibc-ng
The test does not compile with --static. As this does not touch binaries, not bumping the package release. Signed-off-by: Rosen Penev <rosenp@gmail.com>pull/10984/head
parent
cb63deb8e9
commit
3a559224b3
|
@ -0,0 +1,11 @@
|
|||
--- a/tests/Makefile
|
||||
+++ b/tests/Makefile
|
||||
@@ -32,7 +32,7 @@ run_libcap_psx_test: libcap_psx_test
|
||||
./libcap_psx_test
|
||||
|
||||
libcap_psx_test: libcap_psx_test.c $(DEPS)
|
||||
- $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create --static
|
||||
+ $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create
|
||||
|
||||
clean:
|
||||
rm -f psx_test psx_test_wrap libcap_psx_test
|
Loading…
Reference in New Issue