mirror of https://github.com/openwrt/packages.git
vips: update to 8.14.2
Signed-off-by: W. Michael Petullo <mike@flyn.org>pull/21125/head
parent
cb7aa1e2da
commit
4a7822604a
|
@ -6,24 +6,23 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=vips
|
||||
PKG_VERSION:=8.13.3
|
||||
PKG_VERSION:=8.14.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://github.com/libvips/libvips/releases/download/v$(PKG_VERSION)
|
||||
PKG_HASH:=4eff5cdc8dbe1a05a926290a99014e20ba386f5dcca38d9774bef61413435d4c
|
||||
PKG_HASH:=27dad021f0835a5ab14e541d02abd41e4c3bd012d2196438df5a9e754984f7ce
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
PKG_LICENSE:=LGPL-2.1-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_CPE_ID:=cpe:/a:vips:vips
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_DEPENDS:=glib2/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/vips
|
||||
$(call Package/vips/Default)
|
||||
|
@ -31,41 +30,38 @@ define Package/vips
|
|||
CATEGORY:=Multimedia
|
||||
TITLE:=An image manipulation library
|
||||
URL:=https://libvips.github.io/libvips/
|
||||
DEPENDS:=+glib2 +libexif +libexpat +libjpeg +libpng +giflib +libxml2 +libstdcpp $(INTL_DEPENDS)
|
||||
DEPENDS:=+glib2 +libexif +libexpat +libjpeg +libpng +giflib +libxml2
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-debug \
|
||||
--disable-gtk-doc-html \
|
||||
--disable-magickload \
|
||||
--disable-magicksave \
|
||||
--without-analyze \
|
||||
--without-cfitsio \
|
||||
--without-fftw \
|
||||
--without-gsf \
|
||||
--without-imagequant \
|
||||
--without-lcms \
|
||||
--without-libwebp \
|
||||
--without-magick \
|
||||
--without-magickpackage \
|
||||
--without-matio \
|
||||
--without-nifti \
|
||||
--without-OpenEXR \
|
||||
--without-openslide \
|
||||
--without-orc \
|
||||
--without-pangoft2 \
|
||||
--without-pdfium \
|
||||
--without-poppler \
|
||||
--without-ppm \
|
||||
--without-radiance \
|
||||
--without-rsvg \
|
||||
--without-tiff \
|
||||
--without-x \
|
||||
--without-zlib \
|
||||
--with-giflib \
|
||||
--with-jpeg \
|
||||
--with-libexif \
|
||||
--with-png \
|
||||
MESON_ARGS += \
|
||||
-Dgtk_doc=false \
|
||||
-Dintrospection=false \
|
||||
-Danalyze=false \
|
||||
-Dcfitsio=disabled \
|
||||
-Dfftw=disabled \
|
||||
-Dgsf=disabled \
|
||||
-Dimagequant=disabled \
|
||||
-Dlcms=disabled \
|
||||
-Dwebp=disabled \
|
||||
-Dmagick=disabled \
|
||||
-Dmagick-package=disabled \
|
||||
-Dmatio=disabled \
|
||||
-Dnifti=disabled \
|
||||
-Dopenexr=disabled \
|
||||
-Dopenslide=disabled \
|
||||
-Dorc=disabled \
|
||||
-Dpangocairo=disabled \
|
||||
-Dpdfium=disabled \
|
||||
-Dpoppler=disabled \
|
||||
-Dppm=false \
|
||||
-Dradiance=false \
|
||||
-Drsvg=disabled \
|
||||
-Dtiff=disabled \
|
||||
-Dzlib=disabled \
|
||||
-Dcgif=enabled \
|
||||
-Djpeg=enabled \
|
||||
-Dexif=enabled \
|
||||
-Dpng=enabled \
|
||||
|
||||
TARGET_CXXFLAGS += -fno-rtti
|
||||
|
||||
|
@ -74,7 +70,7 @@ define Build/InstallDev
|
|||
$(CP) $(PKG_INSTALL_DIR)/usr/include/vips/* $(1)/usr/include/vips
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libvips.{a,so}* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libvips.so* $(1)/usr/lib/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/vips.pc $(1)/usr/lib/pkgconfig/vips.pc
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -26,7 +26,11 @@ VIPS_MAJOR_VERSION=vips_major_version()
|
||||
VIPS_MINOR_VERSION=vips_minor_version()
|
||||
VIPS_MICRO_VERSION=vips_micro_version()
|
||||
VIPS_VERSION=vips_version()
|
||||
-VIPS_VERSION_STRING="$VIPS_VERSION-$(date -u -r $srcdir/ChangeLog)"
|
||||
+if test "x$SOURCE_DATE_EPOCH" = "x"; then
|
||||
+ VIPS_VERSION_STRING=$VIPS_VERSION-`date -u -r ChangeLog`
|
||||
+else
|
||||
+ VIPS_VERSION_STRING=$VIPS_VERSION-`LC_ALL=C date --utc --date="@$SOURCE_DATE_EPOCH"`
|
||||
+fi
|
||||
|
||||
# packages add to these as we find them
|
||||
VIPS_CFLAGS=""
|
Loading…
Reference in New Issue