mirror of https://github.com/openwrt/packages.git
dcwapd: fix compilation with GCC 14
Old bug in rapidjson. Signed-off-by: Rosen Penev <rosenp@gmail.com>pull/24124/head
parent
cfb9e1cede
commit
4aed8a05a5
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=dcwapd
|
PKG_NAME:=dcwapd
|
||||||
PKG_VERSION:=1.1.0
|
PKG_VERSION:=1.1.0
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=5
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/ewsi/$(PKG_NAME)/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/ewsi/$(PKG_NAME)/tar.gz/v$(PKG_VERSION)?
|
||||||
|
|
|
@ -0,0 +1,14 @@
|
||||||
|
--- a/dcwlinux/include/rapidjson/document.h
|
||||||
|
+++ b/dcwlinux/include/rapidjson/document.h
|
||||||
|
@@ -314,9 +314,9 @@ struct GenericStringRef {
|
||||||
|
GenericStringRef(const CharType* str, SizeType len)
|
||||||
|
: s(str), length(len) { RAPIDJSON_ASSERT(s != 0); }
|
||||||
|
|
||||||
|
- GenericStringRef(const GenericStringRef& rhs) : s(rhs.s), length(rhs.length) {}
|
||||||
|
+ GenericStringRef(const GenericStringRef& rhs) = default;
|
||||||
|
|
||||||
|
- GenericStringRef& operator=(const GenericStringRef& rhs) { s = rhs.s; length = rhs.length; }
|
||||||
|
+ GenericStringRef& operator=(const GenericStringRef& rhs) = default;
|
||||||
|
|
||||||
|
//! implicit conversion to plain CharType pointer
|
||||||
|
operator const Ch *() const { return s; }
|
Loading…
Reference in New Issue