mpd: update to 0.23.16

Add patch to fix compilation with fmt 11.1.

Remove upstreamed patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
pull/25572/head
Rosen Penev 2025-01-06 18:02:46 -08:00
parent c25ee5ab2c
commit 4b0f742e2b
3 changed files with 23 additions and 75 deletions

View File

@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mpd
PKG_VERSION:=0.23.15
PKG_RELEASE:=3
PKG_VERSION:=0.23.16
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.musicpd.org/download/mpd/0.23
PKG_HASH:=550132239ad1acf82ccf8905b56cc13dc2c81a4489b96fba7731b3049907661a
PKG_HASH:=9668e36df80de485683c962d02845bf314d8a08e6141af7afeff76401e32b2c1
PKG_MAINTAINER:=
PKG_LICENSE:=GPL-2.0-or-later

View File

@ -0,0 +1,20 @@
--- a/src/client/Response.hxx
+++ b/src/client/Response.hxx
@@ -83,7 +83,7 @@ public:
template<typename S, typename... Args>
bool Fmt(const S &format_str, Args&&... args) noexcept {
#if FMT_VERSION >= 90000
- return VFmt(format_str,
+ return VFmt(fmt::format_string<Args...>(format_str),
fmt::make_format_args(args...));
#elif FMT_VERSION >= 70000
return VFmt(fmt::to_string_view(format_str),
@@ -113,7 +113,7 @@ public:
void FmtError(enum ack code,
const S &format_str, Args&&... args) noexcept {
#if FMT_VERSION >= 90000
- return VFmtError(code, format_str,
+ return VFmtError(code, fmt::format_string<Args...>(format_str),
fmt::make_format_args(args...));
#elif FMT_VERSION >= 70000
return VFmtError(code, fmt::to_string_view(format_str),

View File

@ -1,72 +0,0 @@
From 1402869715e3efca87942d79c3173a6b21a6925d Mon Sep 17 00:00:00 2001
From: Rudi Heitbaum <rudi@heitbaum.com>
Date: Fri, 5 Jul 2024 14:27:45 +0000
Subject: [PATCH 1/1] lib/fmt: support build with libfmt-11.0.0
Upstream libfmt commit fmtlib/fmt@d707292
now requires the format function to be const.
Adjust the function prototype so it is const and can compile.
Signed-off-by: Rudi Heitbaum <rudi@heitbaum.com>
Signed-off-by: Alexander Egorenkov <egorenar-dev@posteo.net>
---
src/lib/ffmpeg/LibFmt.hxx | 2 +-
src/lib/fmt/AudioFormatFormatter.hxx | 4 ++--
src/lib/fmt/ExceptionFormatter.hxx | 2 +-
src/lib/fmt/PathFormatter.hxx | 2 +-
4 files changed, 5 insertions(+), 5 deletions(-)
--- a/src/lib/ffmpeg/LibFmt.hxx
+++ b/src/lib/ffmpeg/LibFmt.hxx
@@ -29,7 +29,7 @@ template<>
struct fmt::formatter<AVSampleFormat> : formatter<string_view>
{
template<typename FormatContext>
- auto format(const AVSampleFormat format, FormatContext &ctx) {
+ auto format(const AVSampleFormat format, FormatContext &ctx) const {
const char *name = av_get_sample_fmt_name(format);
if (name == nullptr)
name = "?";
--- a/src/lib/fmt/AudioFormatFormatter.hxx
+++ b/src/lib/fmt/AudioFormatFormatter.hxx
@@ -39,7 +39,7 @@ template<>
struct fmt::formatter<SampleFormat> : formatter<string_view>
{
template<typename FormatContext>
- auto format(const SampleFormat format, FormatContext &ctx) {
+ auto format(const SampleFormat format, FormatContext &ctx) const {
return formatter<string_view>::format(sample_format_to_string(format),
ctx);
}
@@ -49,7 +49,7 @@ template<>
struct fmt::formatter<AudioFormat> : formatter<string_view>
{
template<typename FormatContext>
- auto format(const AudioFormat &af, FormatContext &ctx) {
+ auto format(const AudioFormat &af, FormatContext &ctx) const {
return formatter<string_view>::format(ToString(af).c_str(),
ctx);
}
--- a/src/lib/fmt/ExceptionFormatter.hxx
+++ b/src/lib/fmt/ExceptionFormatter.hxx
@@ -38,7 +38,7 @@ template<>
struct fmt::formatter<std::exception_ptr> : formatter<string_view>
{
template<typename FormatContext>
- auto format(std::exception_ptr e, FormatContext &ctx) {
+ auto format(std::exception_ptr e, FormatContext &ctx) const {
return formatter<string_view>::format(GetFullMessage(e), ctx);
}
};
--- a/src/lib/fmt/PathFormatter.hxx
+++ b/src/lib/fmt/PathFormatter.hxx
@@ -29,7 +29,7 @@ template<>
struct fmt::formatter<Path> : formatter<string_view>
{
template<typename FormatContext>
- auto format(Path path, FormatContext &ctx) {
+ auto format(Path path, FormatContext &ctx) const {
return formatter<string_view>::format(path.ToUTF8(), ctx);
}
};