mirror of https://github.com/openwrt/packages.git
atftp: update to 0.7.4
Remove upstreamed patches. Refresh others. Signed-off-by: Rosen Penev <rosenp@gmail.com>pull/14748/head
parent
ebc85bbc9d
commit
50e664e2e0
|
@ -7,12 +7,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=atftp
|
||||
PKG_VERSION:=0.7.2
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=0.7.4
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_HASH:=1ad080674e9f974217b3a703e7356c6c8446dc5e7b2014d0d06e1bfaa11b5041
|
||||
PKG_HASH:=d3c9cd0d971dfc786d7a5f4055c35d4e66aafc8102ac03473ef225bdf7edb26a
|
||||
|
||||
PKG_MAINTAINER:=Daniel Danzberger <daniel@dd-wrt.com>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/tftpd.h
|
||||
+++ b/tftpd.h
|
||||
@@ -46,7 +46,7 @@ struct thread_data {
|
||||
@@ -47,7 +47,7 @@ struct thread_data {
|
||||
char *mc_addr; /* multicast address */
|
||||
struct sockaddr_storage sa_mcast;
|
||||
union ip_mreq_storage mcastaddr;
|
||||
|
|
|
@ -1,44 +0,0 @@
|
|||
--- a/tftp_def.c
|
||||
+++ b/tftp_def.c
|
||||
@@ -133,7 +133,7 @@ int print_eng(double value, char *string
|
||||
/*
|
||||
* This is a strncpy function that take care of string NULL termination
|
||||
*/
|
||||
-inline char *Strncpy(char *to, const char *from, size_t size)
|
||||
+char *Strncpy(char *to, const char *from, size_t size)
|
||||
{
|
||||
strncpy(to, from, size);
|
||||
if (size>0)
|
||||
--- a/tftp_def.h
|
||||
+++ b/tftp_def.h
|
||||
@@ -51,7 +51,7 @@ extern char *tftp_errmsg[9];
|
||||
|
||||
int timeval_diff(struct timeval *res, struct timeval *t1, struct timeval *t0);
|
||||
int print_eng(double value, char *string, int size, char *format);
|
||||
-inline char *Strncpy(char *to, const char *from, size_t size);
|
||||
+char *Strncpy(char *to, const char *from, size_t size);
|
||||
int Gethostbyname(char *addr, struct hostent *host);
|
||||
|
||||
char *sockaddr_print_addr(const struct sockaddr_storage *, char *, size_t);
|
||||
--- a/tftpd.h
|
||||
+++ b/tftpd.h
|
||||
@@ -93,7 +93,7 @@ int tftpd_list_find_multicast_server_and
|
||||
/*
|
||||
* Defined in tftpd_list.c, operation on client structure list.
|
||||
*/
|
||||
-inline void tftpd_clientlist_ready(struct thread_data *thread);
|
||||
+void tftpd_clientlist_ready(struct thread_data *thread);
|
||||
void tftpd_clientlist_remove(struct thread_data *thread,
|
||||
struct client_info *client);
|
||||
void tftpd_clientlist_free(struct thread_data *thread);
|
||||
--- a/tftpd_list.c
|
||||
+++ b/tftpd_list.c
|
||||
@@ -201,7 +201,7 @@ int tftpd_list_find_multicast_server_and
|
||||
return 0;
|
||||
}
|
||||
|
||||
-inline void tftpd_clientlist_ready(struct thread_data *thread)
|
||||
+void tftpd_clientlist_ready(struct thread_data *thread)
|
||||
{
|
||||
pthread_mutex_lock(&thread->client_mutex);
|
||||
thread->client_ready = 1;
|
|
@ -1,154 +0,0 @@
|
|||
--- a/argz.h
|
||||
+++ b/argz.h
|
||||
@@ -38,8 +38,6 @@
|
||||
#ifndef _ARGZ_H
|
||||
#define _ARGZ_H 1
|
||||
|
||||
-#include <features.h>
|
||||
-
|
||||
#define __need_error_t
|
||||
#include <errno.h>
|
||||
#include <string.h> /* Need size_t, and strchr is called below. */
|
||||
@@ -52,16 +50,17 @@
|
||||
typedef int error_t;
|
||||
#endif
|
||||
|
||||
-
|
||||
-__BEGIN_DECLS
|
||||
+#ifdef __cplusplus
|
||||
+extern "C" {
|
||||
+#endif
|
||||
|
||||
/* Make a '\0' separated arg vector from a unix argv vector, returning it in
|
||||
ARGZ, and the total length in LEN. If a memory allocation error occurs,
|
||||
ENOMEM is returned, otherwise 0. The result can be destroyed using free. */
|
||||
extern error_t __argz_create (char *__const __argv[], char **__restrict __argz,
|
||||
- size_t *__restrict __len) __THROW;
|
||||
+ size_t *__restrict __len) __attribute__ ((__nothrow__));
|
||||
extern error_t argz_create (char *__const __argv[], char **__restrict __argz,
|
||||
- size_t *__restrict __len) __THROW;
|
||||
+ size_t *__restrict __len) __attribute__ ((__nothrow__));
|
||||
|
||||
/* Make a '\0' separated arg vector from a SEP separated list in
|
||||
STRING, returning it in ARGZ, and the total length in LEN. If a
|
||||
@@ -69,65 +68,65 @@ extern error_t argz_create (char *__cons
|
||||
The result can be destroyed using free. */
|
||||
extern error_t __argz_create_sep (__const char *__restrict __string,
|
||||
int __sep, char **__restrict __argz,
|
||||
- size_t *__restrict __len) __THROW;
|
||||
+ size_t *__restrict __len) __attribute__ ((__nothrow__));
|
||||
extern error_t argz_create_sep (__const char *__restrict __string,
|
||||
int __sep, char **__restrict __argz,
|
||||
- size_t *__restrict __len) __THROW;
|
||||
+ size_t *__restrict __len) __attribute__ ((__nothrow__));
|
||||
|
||||
/* Returns the number of strings in ARGZ. */
|
||||
extern size_t __argz_count (__const char *__argz, size_t __len)
|
||||
- __THROW __attribute_pure__;
|
||||
+ __attribute__ ((__nothrow__));
|
||||
extern size_t argz_count (__const char *__argz, size_t __len)
|
||||
- __THROW __attribute_pure__;
|
||||
+ __attribute__ ((__nothrow__));
|
||||
|
||||
/* Puts pointers to each string in ARGZ into ARGV, which must be large enough
|
||||
to hold them all. */
|
||||
extern void __argz_extract (__const char *__restrict __argz, size_t __len,
|
||||
- char **__restrict __argv) __THROW;
|
||||
+ char **__restrict __argv) __attribute__ ((__nothrow__));
|
||||
extern void argz_extract (__const char *__restrict __argz, size_t __len,
|
||||
- char **__restrict __argv) __THROW;
|
||||
+ char **__restrict __argv) __attribute__ ((__nothrow__));
|
||||
|
||||
/* Make '\0' separated arg vector ARGZ printable by converting all the '\0's
|
||||
except the last into the character SEP. */
|
||||
-extern void __argz_stringify (char *__argz, size_t __len, int __sep) __THROW;
|
||||
-extern void argz_stringify (char *__argz, size_t __len, int __sep) __THROW;
|
||||
+extern void __argz_stringify (char *__argz, size_t __len, int __sep) __attribute__ ((__nothrow__));
|
||||
+extern void argz_stringify (char *__argz, size_t __len, int __sep) __attribute__ ((__nothrow__));
|
||||
|
||||
/* Append BUF, of length BUF_LEN to the argz vector in ARGZ & ARGZ_LEN. */
|
||||
extern error_t __argz_append (char **__restrict __argz,
|
||||
size_t *__restrict __argz_len,
|
||||
__const char *__restrict __buf, size_t _buf_len)
|
||||
- __THROW;
|
||||
+ __attribute__ ((__nothrow__));
|
||||
extern error_t argz_append (char **__restrict __argz,
|
||||
size_t *__restrict __argz_len,
|
||||
__const char *__restrict __buf, size_t __buf_len)
|
||||
- __THROW;
|
||||
+ __attribute__ ((__nothrow__));
|
||||
|
||||
/* Append STR to the argz vector in ARGZ & ARGZ_LEN. */
|
||||
extern error_t __argz_add (char **__restrict __argz,
|
||||
size_t *__restrict __argz_len,
|
||||
- __const char *__restrict __str) __THROW;
|
||||
+ __const char *__restrict __str) __attribute__ ((__nothrow__));
|
||||
extern error_t argz_add (char **__restrict __argz,
|
||||
size_t *__restrict __argz_len,
|
||||
- __const char *__restrict __str) __THROW;
|
||||
+ __const char *__restrict __str) __attribute__ ((__nothrow__));
|
||||
|
||||
/* Append SEP separated list in STRING to the argz vector in ARGZ &
|
||||
ARGZ_LEN. */
|
||||
extern error_t __argz_add_sep (char **__restrict __argz,
|
||||
size_t *__restrict __argz_len,
|
||||
__const char *__restrict __string, int __delim)
|
||||
- __THROW;
|
||||
+ __attribute__ ((__nothrow__));
|
||||
extern error_t argz_add_sep (char **__restrict __argz,
|
||||
size_t *__restrict __argz_len,
|
||||
__const char *__restrict __string, int __delim)
|
||||
- __THROW;
|
||||
+ __attribute__ ((__nothrow__));
|
||||
|
||||
/* Delete ENTRY from ARGZ & ARGZ_LEN, if it appears there. */
|
||||
extern void __argz_delete (char **__restrict __argz,
|
||||
size_t *__restrict __argz_len,
|
||||
- char *__restrict __entry) __THROW;
|
||||
+ char *__restrict __entry) __attribute__ ((__nothrow__));
|
||||
extern void argz_delete (char **__restrict __argz,
|
||||
size_t *__restrict __argz_len,
|
||||
- char *__restrict __entry) __THROW;
|
||||
+ char *__restrict __entry) __attribute__ ((__nothrow__));
|
||||
|
||||
/* Insert ENTRY into ARGZ & ARGZ_LEN before BEFORE, which should be an
|
||||
existing entry in ARGZ; if BEFORE is NULL, ENTRY is appended to the end.
|
||||
@@ -138,11 +137,11 @@ extern void argz_delete (char **__restri
|
||||
extern error_t __argz_insert (char **__restrict __argz,
|
||||
size_t *__restrict __argz_len,
|
||||
char *__restrict __before,
|
||||
- __const char *__restrict __entry) __THROW;
|
||||
+ __const char *__restrict __entry) __attribute__ ((__nothrow__));
|
||||
extern error_t argz_insert (char **__restrict __argz,
|
||||
size_t *__restrict __argz_len,
|
||||
char *__restrict __before,
|
||||
- __const char *__restrict __entry) __THROW;
|
||||
+ __const char *__restrict __entry) __attribute__ ((__nothrow__));
|
||||
|
||||
/* Replace any occurrences of the string STR in ARGZ with WITH, reallocating
|
||||
ARGZ as necessary. If REPLACE_COUNT is non-zero, *REPLACE_COUNT will be
|
||||
@@ -173,11 +172,11 @@ extern error_t argz_replace (char **__re
|
||||
...;
|
||||
*/
|
||||
extern char *__argz_next (__const char *__restrict __argz, size_t __argz_len,
|
||||
- __const char *__restrict __entry) __THROW;
|
||||
+ __const char *__restrict __entry) __attribute__ ((__nothrow__));
|
||||
extern char *argz_next (__const char *__restrict __argz, size_t __argz_len,
|
||||
- __const char *__restrict __entry) __THROW;
|
||||
+ __const char *__restrict __entry) __attribute__ ((__nothrow__));
|
||||
|
||||
-#ifdef __USE_EXTERN_INLINES
|
||||
+#if 0
|
||||
extern inline char *
|
||||
__argz_next (__const char *__argz, size_t __argz_len,
|
||||
__const char *__entry)
|
||||
@@ -200,6 +199,8 @@ argz_next (__const char *__argz, size_t
|
||||
}
|
||||
#endif /* Use extern inlines. */
|
||||
|
||||
-__END_DECLS
|
||||
+#ifdef __cplusplus
|
||||
+}
|
||||
+#endif
|
||||
|
||||
#endif /* argz.h */
|
Loading…
Reference in New Issue