mirror of https://github.com/openwrt/packages.git
pciutils: Fix pkgconfig file
It's pointing to the host. Signed-off-by: Rosen Penev <rosenp@gmail.com>pull/10656/head
parent
1b2e94e537
commit
5256c104e8
|
@ -1,10 +1,24 @@
|
|||
diff --git a/mt.c b/mt.c
|
||||
index d4058c0..4837808 100644
|
||||
--- a/mt.c
|
||||
+++ b/mt.c
|
||||
@@ -21,6 +21,7 @@
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <fcntl.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <sys/sysmacros.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/utsname.h>
|
||||
|
||||
#include "mtio.h"
|
||||
diff --git a/stinit.c b/stinit.c
|
||||
index 5a50341..af5582c 100644
|
||||
--- a/stinit.c
|
||||
+++ b/stinit.c
|
||||
@@ -16,6 +16,7 @@
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
#include <dirent.h>
|
||||
+#include <limits.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/sysmacros.h>
|
||||
|
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=pciutils
|
||||
PKG_VERSION:=3.6.2
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
|
||||
|
@ -83,6 +83,8 @@ define Build/InstallDev
|
|||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_BUILD_DIR)/lib/libpci.pc $(1)/usr/lib/pkgconfig
|
||||
$(SED) 's,/usr/include,$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/libpci.pc
|
||||
$(SED) 's,/usr/lib,$$$${prefix}/lib,g' $(1)/usr/lib/pkgconfig/libpci.pc
|
||||
$(INSTALL_DIR) $(1)/usr/include/pci
|
||||
$(CP) $(foreach i,pci.h config.h header.h types.h, \
|
||||
$(PKG_BUILD_DIR)/lib/$(i)) $(1)/usr/include/pci
|
||||
|
|
Loading…
Reference in New Issue