mirror of https://github.com/openwrt/packages.git
openvswitch: upgrade to version 2.4.0
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>pull/1640/head
parent
0ffa81ea9e
commit
57e39052a8
|
@ -11,8 +11,8 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=openvswitch
|
||||
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=2.3.90
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=2.4.0
|
||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
@ -21,14 +21,14 @@ PKG_USE_MIPS16:=0
|
|||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/openvswitch/ovs
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=58be9c9fd732b5bdd3d4c2e9b8cc2313f570094d
|
||||
PKG_SOURCE_VERSION:=1b05a9d3298f92525d1c2d91bec11abf0766fdf1
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
||||
SUPPORTED_KERNELS:=LINUX_3_8||LINUX_3_10||LINUX_3_13||LINUX_3_14||LINUX_3_18||LINUX_4_0
|
||||
SUPPORTED_KERNELS:=LINUX_3_8||LINUX_3_10||LINUX_3_13||LINUX_3_14||LINUX_3_18||LINUX_4_0||LINUX_4_1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
|
|
@ -0,0 +1,14 @@
|
|||
diff --git a/tests/test-ovn.c b/tests/test-ovn.c
|
||||
index 60b87de..4ad3697 100644
|
||||
--- a/tests/test-ovn.c
|
||||
+++ b/tests/test-ovn.c
|
||||
@@ -974,6 +974,9 @@ test_tree_shape_exhaustively(struct expr *expr, struct shash *symtab,
|
||||
}
|
||||
|
||||
#ifndef _WIN32
|
||||
+#ifndef WAIT_ANY
|
||||
+#define WAIT_ANY (-1)
|
||||
+#endif
|
||||
static void
|
||||
wait_pid(pid_t *pids, int *n)
|
||||
{
|
Loading…
Reference in New Issue