mirror of https://github.com/openwrt/packages.git
miniupnpc: update to 2.1.20190625
Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>pull/9676/head
parent
3ee32eb9bc
commit
649d8f696b
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=miniupnpc
|
||||
PKG_VERSION:=2.1.20190408
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.1.20190625
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://miniupnp.tuxfamily.org/files
|
||||
PKG_HASH:=a0c46bcf6065d6351a8fa6a0a18dc57d10a16908dbb470908fd2e423511514ec
|
||||
PKG_HASH:=8723f5d7fd7970de23635547700878cd29a5c2bb708b5e5475b2d1d2510317fb
|
||||
|
||||
PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
|
||||
PKG_LICENSE:=BSD-3c
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -38,12 +38,6 @@ if (CMAKE_SYSTEM_NAME STREQUAL "Darwin")
|
||||
@@ -39,12 +39,6 @@ if (CMAKE_SYSTEM_NAME STREQUAL "Darwin")
|
||||
target_compile_definitions(miniupnpc-private INTERFACE _DARWIN_C_SOURCE)
|
||||
endif ()
|
||||
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -66,6 +66,7 @@ set (MINIUPNPC_SOURCES
|
||||
connecthostport.c
|
||||
portlistingparse.c
|
||||
receivedata.c
|
||||
+ listdevices.c
|
||||
connecthostport.h
|
||||
igd_desc_parse.h
|
||||
minisoap.h
|
||||
@@ -142,6 +143,10 @@ if (UPNPC_BUILD_SHARED)
|
||||
add_executable (upnpc-shared upnpc.c)
|
||||
target_link_libraries (upnpc-shared PRIVATE libminiupnpc-shared)
|
||||
target_include_directories(upnpc-shared PRIVATE ${CMAKE_CURRENT_BINARY_DIR})
|
||||
+
|
||||
+ add_executable (listdevices listdevices.c)
|
||||
+ target_link_libraries (listdevices PRIVATE libminiupnpc-shared)
|
||||
+ target_include_directories(listdevices PRIVATE ${CMAKE_CURRENT_BINARY_DIR})
|
||||
endif ()
|
||||
endif ()
|
||||
|
Loading…
Reference in New Issue