mirror of https://github.com/openwrt/packages.git
zerotier: update to 1.14.1
Signed-off-by: Moritz Warning <moritzwarning@web.de>pull/24984/head
parent
aeda25086e
commit
660b10f0dc
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=zerotier
|
||||
PKG_VERSION:=1.14.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.14.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/zerotier/ZeroTierOne/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=7191623a81b0d1b552b9431e8864dd3420783ee518394ac1376cee6aaf033291
|
||||
PKG_HASH:=4f9f40b27c5a78389ed3f3216c850921f6298749e5819e9f2edabb2672ce9ca0
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/ZeroTierOne-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
|
||||
|
|
|
@ -1,9 +1,8 @@
|
|||
From f53004bd22365900a1dbb120dae62ce8b614d31d Mon Sep 17 00:00:00 2001
|
||||
From ec02787ae7c5b6e906ab50bcebcd676d4219c812 Mon Sep 17 00:00:00 2001
|
||||
From: Moritz Warning <moritzwarning@web.de>
|
||||
Date: Mon, 6 May 2024 22:31:57 +0200
|
||||
Subject: [PATCH 1/5] fix miniupnpc/natpmp include paths
|
||||
Date: Tue, 17 Sep 2024 14:17:08 +0200
|
||||
Subject: [PATCH 1/5] fix miniupnpc natpmp include path
|
||||
|
||||
Signed-off-by: Moritz Warning <moritzwarning@web.de>
|
||||
---
|
||||
make-linux.mk | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
@ -1,24 +1,14 @@
|
|||
From c10b5ed4c6c44e36178b0a5a82da9e8eaa957008 Mon Sep 17 00:00:00 2001
|
||||
From 81a632c99b581790344729ad327eb473c4c05260 Mon Sep 17 00:00:00 2001
|
||||
From: Moritz Warning <moritzwarning@web.de>
|
||||
Date: Mon, 6 May 2024 22:34:15 +0200
|
||||
Date: Tue, 17 Sep 2024 15:36:36 +0200
|
||||
Subject: [PATCH 2/5] remove PIE options
|
||||
|
||||
Signed-off-by: Moritz Warning <moritzwarning@web.de>
|
||||
---
|
||||
make-linux.mk | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
make-linux.mk | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
--- a/make-linux.mk
|
||||
+++ b/make-linux.mk
|
||||
@@ -71,7 +71,7 @@ else
|
||||
override CFLAGS+=-Wall -Wno-deprecated -pthread $(INCLUDES) -DNDEBUG $(DEFS)
|
||||
CXXFLAGS?=-O3 -fstack-protector
|
||||
override CXXFLAGS+=-Wall -Wno-deprecated -std=c++17 -pthread $(INCLUDES) -DNDEBUG $(DEFS)
|
||||
- LDFLAGS=-pie -Wl,-z,relro,-z,now
|
||||
+ LDFLAGS=-Wl,-z,relro,-z,now
|
||||
ZT_CARGO_FLAGS=--release
|
||||
endif
|
||||
|
||||
@@ -333,7 +333,7 @@ ifeq ($(ZT_CONTROLLER),1)
|
||||
endif
|
||||
|
||||
|
@ -38,4 +28,4 @@ Signed-off-by: Moritz Warning <moritzwarning@web.de>
|
|||
+#override CXXFLAGS+=-fPIC -fPIE
|
||||
|
||||
# Non-executable stack
|
||||
override ASFLAGS+=--noexecstack
|
||||
override LDFLAGS+=-Wl,-z,noexecstack
|
||||
|
|
|
@ -1,11 +1,8 @@
|
|||
From fee674d5a5c7cc847d7e1925ddf41eea89d915c4 Mon Sep 17 00:00:00 2001
|
||||
From 71ed5b791fb0f7bfe1f564726fdc979b71313fbe Mon Sep 17 00:00:00 2001
|
||||
From: Moritz Warning <moritzwarning@web.de>
|
||||
Date: Mon, 4 Jul 2022 00:10:52 +0200
|
||||
Subject: [PATCH 3/5] fix compilation for arm_cortex-a7+neon
|
||||
Date: Tue, 17 Sep 2024 15:38:01 +0200
|
||||
Subject: [PATCH 3/5] fix compilation for arm_cortex a7 neon
|
||||
|
||||
Fixes "error: 'vrbitq_u8' was not declared in this scope"
|
||||
|
||||
Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
||||
---
|
||||
node/Constants.hpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
|
|
@ -1,9 +1,8 @@
|
|||
From f8b4c4a045a9711c316a5c48b238c24cc0948da1 Mon Sep 17 00:00:00 2001
|
||||
From d6197554b3f52ee9d8d81374141aa82014b4fc7b Mon Sep 17 00:00:00 2001
|
||||
From: Moritz Warning <moritzwarning@web.de>
|
||||
Date: Mon, 6 May 2024 22:35:41 +0200
|
||||
Date: Tue, 17 Sep 2024 15:38:34 +0200
|
||||
Subject: [PATCH 4/5] add missing libatomic
|
||||
|
||||
Signed-off-by: Moritz Warning <moritzwarning@web.de>
|
||||
---
|
||||
make-linux.mk | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
|
|
@ -1,9 +1,8 @@
|
|||
From 2a5a279ac0192bc444cd1c3059169f576817d8b9 Mon Sep 17 00:00:00 2001
|
||||
From 8e89af98ac00b1c9c019865faca7479fa0de6084 Mon Sep 17 00:00:00 2001
|
||||
From: Moritz Warning <moritzwarning@web.de>
|
||||
Date: Mon, 28 Aug 2023 09:48:28 +0200
|
||||
Date: Tue, 17 Sep 2024 21:26:08 +0200
|
||||
Subject: [PATCH 5/5] remove noexecstack
|
||||
|
||||
The compilers for arm_cortex-a9 do not recognize this argument.
|
||||
---
|
||||
make-linux.mk | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
@ -14,8 +13,8 @@ The compilers for arm_cortex-a9 do not recognize this argument.
|
|||
#override CXXFLAGS+=-fPIC -fPIE
|
||||
|
||||
# Non-executable stack
|
||||
-override ASFLAGS+=--noexecstack
|
||||
+# override ASFLAGS+=--noexecstack
|
||||
-override LDFLAGS+=-Wl,-z,noexecstack
|
||||
+#override LDFLAGS+=-Wl,-z,noexecstack
|
||||
|
||||
.PHONY: all
|
||||
all: one
|
||||
|
|
Loading…
Reference in New Issue