mirror of https://github.com/openwrt/packages.git
open-plc-utils: fix compilation with GCC10
Signed-off-by: Rosen Penev <rosenp@gmail.com>pull/12668/head
parent
c11726f14a
commit
6617c64487
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=open-plc-utils
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/qca/open-plc-utils.git
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- a/plc/plc.h
|
||||
+++ b/plc/plc.h
|
||||
@@ -498,7 +498,7 @@ struct __packed plcproperty
|
||||
uint8_t DATA_BUFFER [128];
|
||||
}
|
||||
|
||||
-plcproperty;
|
||||
+extern plcproperty;
|
||||
|
||||
#ifndef __GNUC__
|
||||
#pragma pack (pop)
|
Loading…
Reference in New Issue