mirror of https://github.com/openwrt/packages.git
Revert "glib2: update to 2.78.4"
So that we have a working ModemManager again and can look at the problem
revert the update to version 2.78.4 for now.
Signed-off-by: Florian Eckert <fe@dev.tdt.de>
This reverts commit 08c7b0dfca
.
pull/23459/head
parent
445f75e3f1
commit
7b33b15032
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=glib2
|
||||
PKG_VERSION:=2.78.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=2.74.0
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNOME/glib/$(basename $(PKG_VERSION))
|
||||
PKG_HASH:=24b8e0672dca120cc32d394bccb85844e732e04fe75d18bb0573b2dbc7548f63
|
||||
PKG_HASH:=3652c7f072d7b031a6b5edd623f77ebc5dcd2ae698598abcc89ff39ca75add30
|
||||
|
||||
PKG_MAINTAINER:=Peter Wagner <tripolar@gmx.at>
|
||||
PKG_LICENSE:=LGPL-2.1-or-later
|
||||
|
@ -38,7 +38,7 @@ define Package/glib2
|
|||
CATEGORY:=Libraries
|
||||
DEPENDS:=$(ICONV_DEPENDS) $(INTL_DEPENDS) +zlib +libpthread +libffi +libattr +libpcre2
|
||||
TITLE:=glib 2.0
|
||||
URL:=https://www.gtk.org/
|
||||
URL:=http://www.gtk.org/
|
||||
endef
|
||||
|
||||
define Package/glib2/description
|
||||
|
@ -48,8 +48,16 @@ endef
|
|||
COMP_ARGS= \
|
||||
-Dselinux=disabled \
|
||||
-Dlibmount=disabled \
|
||||
-Dman=false \
|
||||
-Ddtrace=false \
|
||||
-Dsystemtap=false \
|
||||
-Dsysprof=disabled \
|
||||
-Dgtk_doc=false \
|
||||
-Dbsymbolic_functions=true \
|
||||
-Dforce_posix_threads=true \
|
||||
-Dtests=false \
|
||||
-Dinstalled_tests=false \
|
||||
-Doss_fuzz=disabled \
|
||||
-Dglib_debug=disabled \
|
||||
-Dglib_assert=false \
|
||||
-Dglib_checks=true \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -1118,7 +1118,7 @@ if host_system == 'windows' and (cc.get_
|
||||
@@ -1045,7 +1045,7 @@ if host_system == 'windows' and (cc.get_
|
||||
glib_conf.set('HAVE_C99_SNPRINTF', false)
|
||||
glib_conf.set('HAVE_C99_VSNPRINTF', false)
|
||||
glib_conf.set('HAVE_UNIX98_PRINTF', false)
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
--- a/glib/meson.build
|
||||
+++ b/glib/meson.build
|
||||
@@ -402,6 +402,7 @@ pcre2_static_args = []
|
||||
@@ -365,6 +365,7 @@ pcre2_static_args = []
|
||||
|
||||
if use_pcre2_static_flag
|
||||
pcre2_static_args = ['-DPCRE2_STATIC']
|
||||
+ pcre2 = pcre2.as_link_whole()
|
||||
endif
|
||||
|
||||
glib_c_args = ['-DG_LOG_DOMAIN="GLib"'] + glib_c_args_internal + pcre2_static_args
|
||||
glib_c_args = ['-DG_LOG_DOMAIN="GLib"', '-DGLIB_COMPILATION'] + pcre2_static_args + glib_hidden_visibility_args
|
||||
|
|
|
@ -0,0 +1,24 @@
|
|||
From ebcc3c01db27b79af38b42c3c52a79d0225f744c Mon Sep 17 00:00:00 2001
|
||||
From: Seungha Yang <seungha@centricular.com>
|
||||
Date: Sun, 14 Aug 2022 04:56:20 +0900
|
||||
Subject: [PATCH] glib-mkenums: Specify output encoding as UTF-8 explicitly for
|
||||
non-English locale
|
||||
|
||||
Fixup regression introduced by
|
||||
https://gitlab.gnome.org/GNOME/glib/-/merge_requests/2797
|
||||
---
|
||||
gobject/glib-mkenums.in | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
--- a/gobject/glib-mkenums.in
|
||||
+++ b/gobject/glib-mkenums.in
|
||||
@@ -19,6 +19,9 @@ import errno
|
||||
import codecs
|
||||
import locale
|
||||
|
||||
+# Non-english locale systems might complain to unrecognized character
|
||||
+sys.stdout = io.TextIOWrapper(sys.stdout.detach(), encoding='utf-8')
|
||||
+
|
||||
VERSION_STR = '''glib-mkenums version @VERSION@
|
||||
glib-mkenums comes with ABSOLUTELY NO WARRANTY.
|
||||
You may redistribute copies of glib-mkenums under the terms of
|
Loading…
Reference in New Issue