mirror of https://github.com/openwrt/packages.git
gnunet: update to v0.11.3
Signed-off-by: Daniel Golle <daniel@makrotopia.org>pull/8637/head
parent
e60ce1e78d
commit
81b1e6b45c
|
@ -2,11 +2,11 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=gnunet
|
||||
|
||||
PKG_VERSION:=0.11.2
|
||||
PKG_VERSION:=0.11.3
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/gnunet
|
||||
PKG_HASH:=cac5c6c692d8375de733371ee777481d11bf6f2276c951b8759d8f870a1515b5
|
||||
PKG_HASH:=2405db9232ae6ded57e7ff513abdf810c65e3861823b3985717ce990b8d87a37
|
||||
|
||||
PKG_LICENSE:=AGPL-3.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
|
@ -1,115 +0,0 @@
|
|||
diff --git a/src/include/Makefile.am b/src/include/Makefile.am
|
||||
index ca0f6050d..bd8eca256 100644
|
||||
--- a/src/include/Makefile.am
|
||||
+++ b/src/include/Makefile.am
|
||||
@@ -127,6 +127,7 @@ gnunetinclude_HEADERS = \
|
||||
gnunet_time_lib.h \
|
||||
gnunet_transport_service.h \
|
||||
gnunet_transport_address_service.h \
|
||||
+ gnunet_transport_application_service.h \
|
||||
gnunet_transport_communication_service.h \
|
||||
gnunet_transport_core_service.h \
|
||||
gnunet_transport_hello_service.h \
|
||||
--- /dev/null 2019-04-03 22:31:17.799489053 +0200
|
||||
+++ b/src/include/gnunet_transport_application_service.h 2019-04-05 14:30:10.326602964 +0200
|
||||
@@ -0,0 +1,100 @@
|
||||
+/*
|
||||
+ This file is part of GNUnet.
|
||||
+ Copyright (C) 2010-2015, 2018, 2019 GNUnet e.V.
|
||||
+
|
||||
+ GNUnet is free software: you can redistribute it and/or modify it
|
||||
+ under the terms of the GNU Affero General Public License as published
|
||||
+ by the Free Software Foundation, either version 3 of the License,
|
||||
+ or (at your option) any later version.
|
||||
+
|
||||
+ GNUnet is distributed in the hope that it will be useful, but
|
||||
+ WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
+ Affero General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU Affero General Public License
|
||||
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
+
|
||||
+ SPDX-License-Identifier: AGPL3.0-or-later
|
||||
+ */
|
||||
+/**
|
||||
+ * @file
|
||||
+ * Bandwidth allocation API for applications to interact with
|
||||
+ *
|
||||
+ * @author Christian Grothoff
|
||||
+ * @author Matthias Wachs
|
||||
+ *
|
||||
+ * @defgroup TRANSPORT service
|
||||
+ * Bandwidth allocation
|
||||
+ *
|
||||
+ * @{
|
||||
+ */
|
||||
+#ifndef GNUNET_TRANSPORT_APPLICATION_SERVICE_H
|
||||
+#define GNUNET_TRANSPORT_APPLICATION_SERVICE_H
|
||||
+
|
||||
+#include "gnunet_constants.h"
|
||||
+#include "gnunet_util_lib.h"
|
||||
+
|
||||
+/**
|
||||
+ * Handle to the TRANSPORT subsystem for making suggestions about
|
||||
+ * connections the peer would like to have.
|
||||
+ */
|
||||
+struct GNUNET_TRANSPORT_ApplicationHandle;
|
||||
+
|
||||
+
|
||||
+/**
|
||||
+ * Initialize the TRANSPORT application client handle.
|
||||
+ *
|
||||
+ * @param cfg configuration to use
|
||||
+ * @return ats application handle, NULL on error
|
||||
+ */
|
||||
+struct GNUNET_TRANSPORT_ApplicationHandle *
|
||||
+GNUNET_TRANSPORT_application_init (const struct GNUNET_CONFIGURATION_Handle *cfg);
|
||||
+
|
||||
+
|
||||
+/**
|
||||
+ * Shutdown TRANSPORT application client.
|
||||
+ *
|
||||
+ * @param ch handle to destroy
|
||||
+ */
|
||||
+void
|
||||
+GNUNET_TRANSPORT_application_done (struct GNUNET_TRANSPORT_ApplicationHandle *ch);
|
||||
+
|
||||
+
|
||||
+/**
|
||||
+ * Handle for suggestion requests.
|
||||
+ */
|
||||
+struct GNUNET_TRANSPORT_ApplicationSuggestHandle;
|
||||
+
|
||||
+
|
||||
+/**
|
||||
+ * An application would like to communicate with a peer. TRANSPORT should
|
||||
+ * allocate bandwith using a suitable address for requiremetns @a pk
|
||||
+ * to transport.
|
||||
+ *
|
||||
+ * @param ch handle
|
||||
+ * @param peer identity of the peer we need an address for
|
||||
+ * @param pk what kind of application will the application require (can be
|
||||
+ * #GNUNET_MQ_PREFERENCE_NONE, we will still try to connect)
|
||||
+ * @param bw desired bandwith, can be zero (we will still try to connect)
|
||||
+ * @return suggestion handle, NULL if request is already pending
|
||||
+ */
|
||||
+struct GNUNET_TRANSPORT_ApplicationSuggestHandle *
|
||||
+GNUNET_TRANSPORT_application_suggest (struct GNUNET_TRANSPORT_ApplicationHandle *ch,
|
||||
+ const struct GNUNET_PeerIdentity *peer,
|
||||
+ enum GNUNET_MQ_PreferenceKind pk,
|
||||
+ struct GNUNET_BANDWIDTH_Value32NBO bw);
|
||||
+
|
||||
+
|
||||
+/**
|
||||
+ * We no longer care about communicating with a peer.
|
||||
+ *
|
||||
+ * @param sh handle
|
||||
+ */
|
||||
+void
|
||||
+GNUNET_TRANSPORT_application_suggest_cancel (struct GNUNET_TRANSPORT_ApplicationSuggestHandle *sh);
|
||||
+
|
||||
+/** @} */ /* end of group */
|
||||
+
|
||||
+#endif
|
||||
+/* end of file gnunet_ats_application_service.h */
|
|
@ -0,0 +1,33 @@
|
|||
diff --git a/src/abe/Makefile.am b/src/abe/Makefile.am
|
||||
index 23a7ae68e..cccd3ccb0 100644
|
||||
--- a/src/abe/Makefile.am
|
||||
+++ b/src/abe/Makefile.am
|
||||
@@ -20,6 +20,8 @@ libgnunetabe_la_LIBADD = \
|
||||
$(LTLIBICONV) \
|
||||
$(LTLIBINTL) \
|
||||
$(ABE_LIBADD) \
|
||||
+ $(top_builddir)/src/util/libgnunetutil.la \
|
||||
+ -lgmp \
|
||||
-lgabe \
|
||||
-lpbc \
|
||||
-lglib-2.0 \
|
||||
diff --git a/src/reclaim/Makefile.am b/src/reclaim/Makefile.am
|
||||
index 13918508e..be50cce26 100644
|
||||
--- a/src/reclaim/Makefile.am
|
||||
+++ b/src/reclaim/Makefile.am
|
||||
@@ -99,6 +99,7 @@ libgnunet_plugin_reclaim_sqlite_la_LIBADD = \
|
||||
libgnunetreclaim.la \
|
||||
$(top_builddir)/src/sq/libgnunetsq.la \
|
||||
$(top_builddir)/src/statistics/libgnunetstatistics.la \
|
||||
+ $(top_builddir)/src/reclaim-attribute/libgnunetreclaimattribute.la \
|
||||
$(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
|
||||
$(LTLIBINTL)
|
||||
libgnunet_plugin_reclaim_sqlite_la_LDFLAGS = \
|
||||
@@ -126,6 +127,7 @@ libgnunetreclaim_la_SOURCES = \
|
||||
reclaim.h
|
||||
libgnunetreclaim_la_LIBADD = \
|
||||
$(top_builddir)/src/util/libgnunetutil.la \
|
||||
+ $(top_builddir)/src/reclaim-attribute/libgnunetreclaimattribute.la \
|
||||
$(GN_LIBINTL) $(XLIB)
|
||||
libgnunetreclaim_la_LDFLAGS = \
|
||||
$(GN_LIB_LDFLAGS) $(WINFLAGS) \
|
|
@ -1,227 +0,0 @@
|
|||
From 53969c9d9a95234ee845fa0542a330f788ad2a2c Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Golle <daniel@makrotopia.org>
|
||||
Date: Fri, 5 Apr 2019 14:41:44 +0200
|
||||
Subject: [PATCH] include credential_*.h in dist
|
||||
|
||||
---
|
||||
src/credential/Makefile.am | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/credential/Makefile.am b/src/credential/Makefile.am
|
||||
index aaac0d2c2..f2550eca6 100644
|
||||
--- a/src/credential/Makefile.am
|
||||
+++ b/src/credential/Makefile.am
|
||||
@@ -70,7 +70,9 @@ gnunet_service_credential_LDADD = \
|
||||
libgnunetcredential_la_SOURCES = \
|
||||
credential_api.c credential.h \
|
||||
credential_serialization.c \
|
||||
- credential_misc.c
|
||||
+ credential_serialization.h \
|
||||
+ credential_misc.c \
|
||||
+ credential_misc.h
|
||||
libgnunetcredential_la_LIBADD = \
|
||||
$(top_builddir)/src/util/libgnunetutil.la $(XLIB)
|
||||
libgnunetcredential_la_LDFLAGS = \
|
||||
--
|
||||
2.21.0
|
||||
|
||||
--- /dev/null 2019-04-03 22:31:17.799489053 +0200
|
||||
+++ b/src/credential/credential_serialization.h 2019-01-28 21:42:05.304419524 +0100
|
||||
@@ -0,0 +1,159 @@
|
||||
+/*
|
||||
+ This file is part of GNUnet.
|
||||
+ Copyright (C) 2009-2013, 2016 GNUnet e.V.
|
||||
+
|
||||
+ GNUnet is free software: you can redistribute it and/or modify it
|
||||
+ under the terms of the GNU Affero General Public License as published
|
||||
+ by the Free Software Foundation, either version 3 of the License,
|
||||
+ or (at your option) any later version.
|
||||
+
|
||||
+ GNUnet is distributed in the hope that it will be useful, but
|
||||
+ WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
+ Affero General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU Affero General Public License
|
||||
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
+
|
||||
+ SPDX-License-Identifier: AGPL3.0-or-later
|
||||
+*/
|
||||
+
|
||||
+
|
||||
+/**
|
||||
+ * @file credential/credential_serialization.h
|
||||
+ * @brief API to serialize and deserialize delegation chains
|
||||
+ * and credentials
|
||||
+ * @author Martin Schanzenbach
|
||||
+ */
|
||||
+#ifndef CREDENTIAL_SERIALIZATION_H
|
||||
+#define CREDENTIAL_SERIALIZATION_H
|
||||
+
|
||||
+#include "platform.h"
|
||||
+#include "gnunet_util_lib.h"
|
||||
+#include "gnunet_constants.h"
|
||||
+#include "gnunet_credential_service.h"
|
||||
+
|
||||
+/**
|
||||
+ * Calculate how many bytes we will need to serialize
|
||||
+ * the given delegation record
|
||||
+ *
|
||||
+ * @param ds_count number of delegation chain entries
|
||||
+ * @param dsr array of #GNUNET_CREDENTIAL_Delegation
|
||||
+ * @return the required size to serialize
|
||||
+ */
|
||||
+size_t
|
||||
+GNUNET_CREDENTIAL_delegation_set_get_size (unsigned int ds_count,
|
||||
+ const struct GNUNET_CREDENTIAL_DelegationSet *dsr);
|
||||
+
|
||||
+/**
|
||||
+ * Serizalize the given delegation record entries
|
||||
+ *
|
||||
+ * @param d_count number of delegation chain entries
|
||||
+ * @param dsr array of #GNUNET_CREDENTIAL_Delegation
|
||||
+ * @param dest_size size of the destination
|
||||
+ * @param dest where to store the result
|
||||
+ * @return the size of the data, -1 on failure
|
||||
+ */
|
||||
+ssize_t
|
||||
+GNUNET_CREDENTIAL_delegation_set_serialize (unsigned int d_count,
|
||||
+ const struct GNUNET_CREDENTIAL_DelegationSet *dsr,
|
||||
+ size_t dest_size,
|
||||
+ char *dest);
|
||||
+
|
||||
+
|
||||
+/**
|
||||
+ * Deserialize the given destination
|
||||
+ *
|
||||
+ * @param len size of the serialized delegation recird
|
||||
+ * @param src the serialized data
|
||||
+ * @param d_count the number of delegation chain entries
|
||||
+ * @param dsr where to put the delegation chain entries
|
||||
+ * @return #GNUNET_OK on success, #GNUNET_SYSERR on error
|
||||
+ */
|
||||
+int
|
||||
+GNUNET_CREDENTIAL_delegation_set_deserialize (size_t len,
|
||||
+ const char *src,
|
||||
+ unsigned int d_count,
|
||||
+ struct GNUNET_CREDENTIAL_DelegationSet *dsr);
|
||||
+
|
||||
+ /**
|
||||
+ * Calculate how many bytes we will need to serialize
|
||||
+ * the given delegation chain and credential
|
||||
+ *
|
||||
+ * @param d_count number of delegation chain entries
|
||||
+ * @param dd array of #GNUNET_CREDENTIAL_Delegation
|
||||
+ * @param c_count number of credential entries
|
||||
+ * @param cd a #GNUNET_CREDENTIAL_Credential
|
||||
+ * @return the required size to serialize
|
||||
+ */
|
||||
+ size_t
|
||||
+ GNUNET_CREDENTIAL_delegation_chain_get_size (unsigned int d_count,
|
||||
+ const struct GNUNET_CREDENTIAL_Delegation *dd,
|
||||
+ unsigned int c_count,
|
||||
+ const struct GNUNET_CREDENTIAL_Credential *cd);
|
||||
+
|
||||
+ /**
|
||||
+ * Serizalize the given delegation chain entries and credential
|
||||
+ *
|
||||
+ * @param d_count number of delegation chain entries
|
||||
+ * @param dd array of #GNUNET_CREDENTIAL_Delegation
|
||||
+ * @param c_count number of credential entries
|
||||
+ * @param cd a #GNUNET_CREDENTIAL_Credential
|
||||
+ * @param dest_size size of the destination
|
||||
+ * @param dest where to store the result
|
||||
+ * @return the size of the data, -1 on failure
|
||||
+ */
|
||||
+ ssize_t
|
||||
+ GNUNET_CREDENTIAL_delegation_chain_serialize (unsigned int d_count,
|
||||
+ const struct GNUNET_CREDENTIAL_Delegation *dd,
|
||||
+ unsigned int c_count,
|
||||
+ const struct GNUNET_CREDENTIAL_Credential *cd,
|
||||
+ size_t dest_size,
|
||||
+ char *dest);
|
||||
+
|
||||
+
|
||||
+ /**
|
||||
+ * Deserialize the given destination
|
||||
+ *
|
||||
+ * @param len size of the serialized delegation chain and cred
|
||||
+ * @param src the serialized data
|
||||
+ * @param d_count the number of delegation chain entries
|
||||
+ * @param dd where to put the delegation chain entries
|
||||
+ * @param c_count number of credential entries
|
||||
+ * @param cd where to put the credential data
|
||||
+ * @return #GNUNET_OK on success, #GNUNET_SYSERR on error
|
||||
+ */
|
||||
+ int
|
||||
+ GNUNET_CREDENTIAL_delegation_chain_deserialize (size_t len,
|
||||
+ const char *src,
|
||||
+ unsigned int d_count,
|
||||
+ struct GNUNET_CREDENTIAL_Delegation *dd,
|
||||
+ unsigned int c_count,
|
||||
+ struct GNUNET_CREDENTIAL_Credential *cd);
|
||||
+ size_t
|
||||
+ GNUNET_CREDENTIAL_credentials_get_size (unsigned int c_count,
|
||||
+ const struct GNUNET_CREDENTIAL_Credential *cd);
|
||||
+
|
||||
+ssize_t
|
||||
+GNUNET_CREDENTIAL_credentials_serialize (unsigned int c_count,
|
||||
+ const struct GNUNET_CREDENTIAL_Credential *cd,
|
||||
+ size_t dest_size,
|
||||
+ char *dest);
|
||||
+
|
||||
+
|
||||
+int
|
||||
+GNUNET_CREDENTIAL_credentials_deserialize (size_t len,
|
||||
+ const char *src,
|
||||
+ unsigned int c_count,
|
||||
+ struct GNUNET_CREDENTIAL_Credential *cd);
|
||||
+
|
||||
+
|
||||
+int
|
||||
+GNUNET_CREDENTIAL_credential_serialize (struct GNUNET_CREDENTIAL_Credential *cred,
|
||||
+ char **data);
|
||||
+
|
||||
+struct GNUNET_CREDENTIAL_Credential*
|
||||
+GNUNET_CREDENTIAL_credential_deserialize (const char* data,
|
||||
+ size_t data_size);
|
||||
+#endif
|
||||
+/* end of credential_serialization.h */
|
||||
--- /dev/null 2019-04-03 22:31:17.799489053 +0200
|
||||
+++ b/src/credential/credential_misc.h 2019-01-28 21:42:05.304419524 +0100
|
||||
@@ -0,0 +1,35 @@
|
||||
+/*
|
||||
+ This file is part of GNUnet
|
||||
+ Copyright (C) 2012-2013 GNUnet e.V.
|
||||
+
|
||||
+ GNUnet is free software: you can redistribute it and/or modify it
|
||||
+ under the terms of the GNU Affero General Public License as published
|
||||
+ by the Free Software Foundation, either version 3 of the License,
|
||||
+ or (at your option) any later version.
|
||||
+
|
||||
+ GNUnet is distributed in the hope that it will be useful, but
|
||||
+ WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
+ Affero General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU Affero General Public License
|
||||
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
+
|
||||
+ SPDX-License-Identifier: AGPL3.0-or-later
|
||||
+ */
|
||||
+/**
|
||||
+ * @file credential/credential_misc.h
|
||||
+ * @brief Credential helper functions
|
||||
+ */
|
||||
+#ifndef CREDENTIAL_MISC_H
|
||||
+#define CREDENTIAL_MISC_H
|
||||
+
|
||||
+
|
||||
+
|
||||
+char*
|
||||
+GNUNET_CREDENTIAL_credential_to_string (const struct GNUNET_CREDENTIAL_Credential *cred);
|
||||
+
|
||||
+struct GNUNET_CREDENTIAL_Credential*
|
||||
+GNUNET_CREDENTIAL_credential_from_string (const char* str);
|
||||
+
|
||||
+#endif
|
Loading…
Reference in New Issue