mirror of https://github.com/openwrt/packages.git
diffutils: update to 3.10
- Switch package URL to HTTPS - Refresh the patch Signed-off-by: krant <aleksey.vasilenko@gmail.com>pull/23331/head
parent
2ce8d58722
commit
8e1c788059
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=diffutils
|
||||
PKG_VERSION:=3.8
|
||||
PKG_VERSION:=3.10
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNU/diffutils
|
||||
PKG_HASH:=a6bdd7d1b31266d11c4f4de6c1b748d4607ab0231af5188fc2533d0ae2438fec
|
||||
PKG_HASH:=90e5e93cc724e4ebe12ede80df1634063c7a855692685919bfe60b556c9bd09e
|
||||
|
||||
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
|
||||
PKG_LICENSE:=GPL-3.0
|
||||
|
@ -30,7 +30,7 @@ define Package/diffutils
|
|||
CATEGORY:=Development
|
||||
DEPENDS:=+USE_GLIBC:librt
|
||||
TITLE:=diffutils
|
||||
URL:=http://www.gnu.org/software/diffutils/
|
||||
URL:=https://www.gnu.org/software/diffutils/
|
||||
ALTERNATIVES:=\
|
||||
200:/usr/bin/cmp:/usr/libexec/cmp-gnu \
|
||||
200:/usr/bin/diff:/usr/libexec/diff-gnu
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
--- a/lib/sigsegv.c
|
||||
+++ b/lib/sigsegv.c
|
||||
@@ -219,8 +219,8 @@ int libsigsegv_version = LIBSIGSEGV_VERS
|
||||
# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gp_regs[1]
|
||||
# else /* 32-bit */
|
||||
/* both should be equivalent */
|
||||
-# if 0
|
||||
-# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
|
||||
+# ifndef __GLIBC__
|
||||
+# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
|
||||
# else
|
||||
# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
|
||||
# endif
|
||||
@@ -244,8 +244,8 @@ int libsigsegv_version = LIBSIGSEGV_VERS
|
||||
/* Assume the structure of ucontext_t in
|
||||
glibc/sysdeps/unix/sysv/linux/powerpc/sys/ucontext.h. */
|
||||
/* Because of the union, both definitions should be equivalent. */
|
||||
-# if 0
|
||||
-# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
|
||||
+# ifndef __GLIBC__
|
||||
+# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
|
||||
# else
|
||||
# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
|
||||
# endif
|
||||
|
|
Loading…
Reference in New Issue