mirror of https://github.com/openwrt/packages.git
rtklib: Update to 2.4.3_b32
Some minor adjustments. Signed-off-by: Rosen Penev <rosenp@gmail.com>pull/9593/head
parent
64c358876e
commit
9a552c75b3
|
@ -1,4 +1,4 @@
|
|||
#
|
||||
#
|
||||
# Copyright (C) 2014-2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
|
@ -7,18 +7,18 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=rtklib
|
||||
PKG_VERSION:=2.4.3_b24
|
||||
PKG_RELEASE:=$(PKG_SOURCE_VERSION)
|
||||
PKG_VERSION:=2.4.3_b32
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=git://github.com/tomojitakasu/RTKLIB.git
|
||||
PKG_SOURCE_VERSION:=1cec90a9ffa424908ad1a4ca3d52f33f9b94d1f7
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
PKG_MIRROR_HASH:=edda6c29ba3d2f5401145a1497e88646fa0c13afc31ade7bdd982bd8e8081c6a
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_LICENSE:=BSD-2-Clause
|
||||
PKG_SOURCE_URL:=https://github.com/tomojitakasu/RTKLIB
|
||||
PKG_SOURCE_VERSION:=6e5ddadb737c54d4a43c43feeeb4e244c51b4286
|
||||
PKG_MIRROR_HASH:=b6ada49b6667a98e935055e718bf9a5712030cddc1694d1be7c0ab0e98bdc7b8
|
||||
|
||||
PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
|
||||
PKG_LICENSE:=BSD-2-Clause
|
||||
|
||||
PKG_BUILD_PARALLEL:=0
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
|
|
@ -0,0 +1,12 @@
|
|||
--- a/src/stream.c
|
||||
+++ b/src/stream.c
|
||||
@@ -81,6 +81,9 @@
|
||||
#include <netinet/in.h>
|
||||
#include <netinet/tcp.h>
|
||||
#include <arpa/inet.h>
|
||||
+#ifndef _POSIX_SOURCE
|
||||
+#define _POSIX_SOURCE
|
||||
+#endif
|
||||
#include <netdb.h>
|
||||
#endif
|
||||
|
|
@ -0,0 +1,21 @@
|
|||
--- a/app/rnx2rtkp/gcc/makefile
|
||||
+++ b/app/rnx2rtkp/gcc/makefile
|
||||
@@ -2,14 +2,14 @@
|
||||
BINDIR = /usr/local/bin
|
||||
SRC = ../../../src
|
||||
|
||||
-#OPTS = -DTRACE -DENAGLO -DENAQZS -DENAGAL -DENACMP -DENAIRN -DNFREQ=3
|
||||
-OPTS = -DTRACE -DENAGLO -DENAQZS -DENAGAL -DENACMP -DENAIRN -DNFREQ=3 -DIERS_MODEL
|
||||
+OPTS = -DTRACE -DENAGLO -DENAQZS -DENAGAL -DENACMP -DENAIRN -DNFREQ=3
|
||||
+#OPTS = -DTRACE -DENAGLO -DENAQZS -DENAGAL -DENACMP -DENAIRN -DNFREQ=3 -DIERS_MODEL
|
||||
#OPTS = -DENAGLO -DENAQZS -DENAGAL -DENACMP -DNFREQ=2
|
||||
|
||||
# for no lapack
|
||||
CFLAGS = -Wall -O3 -ansi -pedantic -Wno-unused-but-set-variable -I$(SRC) $(OPTS) -g
|
||||
-#LDLIBS = -lm -lrt
|
||||
-LDLIBS = ../../../lib/iers/gcc/iers.a -lgfortran -lm -lrt
|
||||
+LDLIBS = -lm -lrt
|
||||
+#LDLIBS = ../../../lib/iers/gcc/iers.a -lgfortran -lm -lrt
|
||||
|
||||
#CFLAGS = -Wall -O3 -ansi -pedantic -Wno-unused-but-set-variable -I$(SRC) -DLAPACK $(OPTS)
|
||||
#LDLIBS = -lm -lrt -llapack -lblas
|
Loading…
Reference in New Issue