mirror of https://github.com/openwrt/packages.git
postfix: less overlayfs rewrites
Signed-off-by: Denis Shulyaka <Shulyaka@gmail.com>pull/4664/head
parent
7a739beaba
commit
ab4e5c53de
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=postfix
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
PKG_SOURCE_URL:=ftp://ftp.porcupine.org/mirrors/postfix-release/official/
|
||||
PKG_VERSION:=3.2.2
|
||||
PKG_HASH:=d06849418d119d09366997b2b481bb23f737629769b4e4a52da42fb3ad8b0576
|
||||
|
|
|
@ -0,0 +1,24 @@
|
|||
diff -Naur a/conf/post-install b/conf/post-install
|
||||
--- a/conf/post-install 2015-12-28 00:00:45.000000000 +0000
|
||||
+++ b/conf/post-install 2017-08-01 22:42:30.476896711 +0000
|
||||
@@ -561,15 +561,16 @@
|
||||
then
|
||||
set_permission=1
|
||||
fi
|
||||
+ test -n "$recursive" && nonrecursive="" || nonrecursive="-maxdepth 0"
|
||||
test -n "$set_permission" && {
|
||||
- chown $recursive $owner $path || exit 1
|
||||
- test -z "$group" || chgrp $recursive $group $path || exit 1
|
||||
+ find $path $nonrecursive ! -user $owner -exec chown $owner "{}" ";" || exit 1
|
||||
+ test -z "$group" || find $path $nonrecursive ! -group $group -exec chgrp $group "{}" ";" || exit 1
|
||||
# Don't "chmod -R"; queue file status is encoded in mode bits.
|
||||
if [ "$type" = "d" -a -n "$recursive" ]
|
||||
then
|
||||
- find $path -type d -exec chmod $mode "{}" ";"
|
||||
+ find $path -type d -a ! -perm $mode -exec chmod $mode "{}" ";"
|
||||
else
|
||||
- chmod $mode $path
|
||||
+ find $path $nonrecursive ! -perm $mode -exec chmod $mode "{}" ";"
|
||||
fi || exit 1
|
||||
}
|
||||
done
|
Loading…
Reference in New Issue