gst1-plugins-good: update to 1.22.12

Signed-off-by: Rosen Penev <rosenp@gmail.com>
pull/24249/head
Rosen Penev 2024-05-27 11:35:40 -07:00
parent d7053d7a78
commit b37899cab9
2 changed files with 20 additions and 2 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gst1-plugins-good
PKG_VERSION:=1.22.8
PKG_VERSION:=1.22.12
PKG_RELEASE:=1
PKG_SOURCE:=gst-plugins-good-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gst-plugins-good/
PKG_HASH:=e305b9f07f52743ca481da0a4e0c76c35efd60adaf1b0694eb3bb021e2137e39
PKG_HASH:=9c1913f981900bd8867182639b20907b28ed78ef7a222cfbf2d8ba9dab992fa7
PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-good-$(PKG_VERSION)
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
@ -87,6 +87,8 @@ define Package/gstreamer1-plugins-good/config
endef
TARGET_CFLAGS += -Wno-error=incompatible-pointer-types
GST_COND_SELECT = -D$(1)=$(if $(CONFIG_PACKAGE_gst1-mod-$(1)),en,dis)abled
GST_VERSION:=1.0

View File

@ -0,0 +1,16 @@
--- a/sys/v4l2/gstv4l2object.h
+++ b/sys/v4l2/gstv4l2object.h
@@ -74,10 +74,10 @@ typedef gboolean (*GstV4l2UpdateFpsFunc
/* On Android NDK r18b the ioctl() signature uses 'unsigned' instead of
* 'unsigned long' for the 2nd parameter */
-#ifdef __ANDROID__
-typedef unsigned ioctl_req_t;
-#else
+#ifdef __GLIBC__
typedef gulong ioctl_req_t;
+#else
+typedef int ioctl_req_t;
#endif
#define GST_V4L2_WIDTH(o) (GST_VIDEO_INFO_WIDTH (&(o)->info))