mirror of https://github.com/openwrt/packages.git
openssh: bump to 9.9p1
Release notes: https://www.openssh.com/txt/release-9.9
Added upstream patch to fix build[1]
1. 76a618d284
.patch
Build system: x86/64
Build-tested: x86/64/AMD Cezanne
Run-tested: x86/64/AMD Cezanne
Signed-off-by: John Audia <therealgraysky@proton.me>
pull/25040/head
parent
b1635b899d
commit
b90e9b7eba
|
@ -8,14 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=openssh
|
||||
PKG_REALVERSION:=9.8p1
|
||||
PKG_VERSION:=9.8_p1
|
||||
PKG_RELEASE:=2
|
||||
PKG_REALVERSION:=9.9p1
|
||||
PKG_VERSION:=9.9_p1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_REALVERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://cdn.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
|
||||
https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/
|
||||
PKG_HASH:=dd8bd002a379b5d499dfb050dd1fa9af8029e80461f4bb6c523c49973f5a39f3
|
||||
PKG_HASH:=b343fbcdbff87f15b1986e6e15d6d4fc9a7d36066be6b7fb507087ba8f966c02
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(if $(BUILD_VARIANT),$(PKG_NAME)-$(BUILD_VARIANT)/)$(PKG_NAME)-$(PKG_REALVERSION)
|
||||
|
||||
PKG_LICENSE:=BSD ISC
|
||||
|
|
|
@ -0,0 +1,30 @@
|
|||
From 76a618d2842c34c16cd21a4efc7230e2f459008d Mon Sep 17 00:00:00 2001
|
||||
From: Damien Miller <djm@mindrot.org>
|
||||
Date: Wed, 25 Sep 2024 11:13:05 +1000
|
||||
Subject: [PATCH] build construct_utmp() when USE_BTMP is set
|
||||
|
||||
Fixes compile error on Void Linux/Musl
|
||||
---
|
||||
loginrec.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/loginrec.c
|
||||
+++ b/loginrec.c
|
||||
@@ -614,7 +614,7 @@ line_abbrevname(char *dst, const char *s
|
||||
** into account.
|
||||
**/
|
||||
|
||||
-#if defined(USE_UTMP) || defined (USE_WTMP) || defined (USE_LOGIN)
|
||||
+#if defined(USE_BTMP) || defined(USE_UTMP) || defined (USE_WTMP) || defined (USE_LOGIN)
|
||||
|
||||
/* build the utmp structure */
|
||||
void
|
||||
@@ -698,7 +698,7 @@ construct_utmp(struct logininfo *li,
|
||||
}
|
||||
# endif
|
||||
}
|
||||
-#endif /* USE_UTMP || USE_WTMP || USE_LOGIN */
|
||||
+#endif /* USE_BTMP || USE_UTMP || USE_WTMP || USE_LOGIN */
|
||||
|
||||
/**
|
||||
** utmpx utility functions
|
|
@ -1,11 +0,0 @@
|
|||
--- a/openbsd-compat/port-linux.c
|
||||
+++ b/openbsd-compat/port-linux.c
|
||||
@@ -366,7 +366,7 @@ ssh_systemd_notify(const char *fmt, ...)
|
||||
error_f("socket \"%s\": %s", path, strerror(errno));
|
||||
goto out;
|
||||
}
|
||||
- if (connect(fd, &addr, sizeof(addr)) != 0) {
|
||||
+ if (connect(fd, (struct sockaddr *)&addr, sizeof(addr)) != 0) {
|
||||
error_f("socket \"%s\" connect: %s", path, strerror(errno));
|
||||
goto out;
|
||||
}
|
Loading…
Reference in New Issue