mirror of https://github.com/openwrt/packages.git
unixodbc: fix compilation with GCC14
Wrong pointer type. Signed-off-by: Rosen Penev <rosenp@gmail.com>pull/24183/head
parent
8d57f843ba
commit
b914fd47ca
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=unixodbc
|
||||
PKG_VERSION:=2.3.12
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=unixODBC-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.unixodbc.org
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- a/Drivers/Postgre7.1/info.c
|
||||
+++ b/Drivers/Postgre7.1/info.c
|
||||
@@ -1786,7 +1786,7 @@ HSTMT hcol_stmt;
|
||||
StatementClass *col_stmt, *indx_stmt;
|
||||
char column_name[MAX_INFO_STRING], relhasrules[MAX_INFO_STRING];
|
||||
char **column_names = 0;
|
||||
-Int4 column_name_len;
|
||||
+SQLLEN column_name_len;
|
||||
int total_columns = 0;
|
||||
char error = TRUE;
|
||||
ConnInfo *ci;
|
Loading…
Reference in New Issue