libshout: fix compilation with GCC14

Missing headers.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
pull/24233/head
Rosen Penev 2024-05-21 18:57:43 -07:00
parent baf2e06d17
commit bfe0d361f3
2 changed files with 12 additions and 1 deletions
libs/libshout

View File

@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libshout
PKG_VERSION:=2.4.6
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://downloads.us.xiph.org/releases/libshout/

View File

@ -0,0 +1,11 @@
--- a/src/shout_private.h
+++ b/src/shout_private.h
@@ -33,6 +33,8 @@
#include <common/timing/timing.h>
#include "util.h"
+#include <stdio.h>
+#include <stdlib.h>
#include <sys/types.h>
#ifdef HAVE_STDINT_H