mirror of https://github.com/openwrt/packages.git
davfs2: update to 1.6.0
Removed now unnecessary gcc10 patch. Removed neon patch. It's now upstream. Signed-off-by: Rosen Penev <rosenp@gmail.com>pull/13174/head
parent
f7041ed34a
commit
c03f25a00a
|
@ -8,19 +8,20 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=davfs2
|
||||
PKG_VERSION:=1.5.6
|
||||
PKG_VERSION:=1.6.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SAVANNAH/davfs2
|
||||
PKG_HASH:=417476cdcfd53966b2dcfaf12455b54f315959b488a89255ab4b44586153d801
|
||||
PKG_HASH:=2e6b675685bd917772be60f0999ae098c80f79ff20dc131e8fec4547cbb63b50
|
||||
|
||||
PKG_MAINTAINER:=Federico Di Marco <fededim@gmail.com>
|
||||
PKG_LICENSE:=GPL-3
|
||||
PKG_LICENSE:=GPL-3.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_CPE_ID:=cpe:/a:davfs2:davfs2
|
||||
|
||||
PKG_FIXUP:=gettext-version autoreconf
|
||||
PKG_FIXUP:=gettext-version
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
@ -57,8 +58,6 @@ endef
|
|||
|
||||
CONFIGURE_ARGS += \
|
||||
--with-neon="$(STAGING_DIR)/usr" \
|
||||
--without-libiconv-prefix \
|
||||
--without-libintl-prefix \
|
||||
--disable-rpath
|
||||
|
||||
define Package/davfs2/install
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -36,7 +36,7 @@ AC_PROG_LN_S
|
||||
# Checks for libraries.
|
||||
AM_GNU_GETTEXT_VERSION(0.18.1)
|
||||
AM_GNU_GETTEXT([external])
|
||||
-NE_REQUIRE_VERSIONS([0], [27 28 29 30])
|
||||
+NE_REQUIRE_VERSIONS([0], [27 28 29 30 31])
|
||||
DAV_CHECK_NEON
|
||||
|
||||
# Checks for header files.
|
|
@ -69,12 +69,13 @@
|
|||
+#endif /* _COMPAT_H */
|
||||
--- a/src/kernel_interface.c
|
||||
+++ b/src/kernel_interface.c
|
||||
@@ -19,8 +19,8 @@
|
||||
@@ -19,9 +19,9 @@
|
||||
|
||||
|
||||
#include "config.h"
|
||||
+#include "compat.h"
|
||||
|
||||
#include <errno.h>
|
||||
-#include <error.h>
|
||||
#ifdef HAVE_FCNTL_H
|
||||
#include <fcntl.h>
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/src/dav_coda.c
|
||||
+++ b/src/dav_coda.c
|
||||
@@ -97,7 +97,7 @@ static unsigned int blocksize;
|
||||
static size_t alignment;
|
||||
|
||||
/* Send debug messages to syslog if != 0. */
|
||||
-int debug;
|
||||
+extern int debug;
|
||||
|
||||
|
||||
/* Private function prototypes */
|
Loading…
Reference in New Issue