schroot: add boost-1.85 compatibility patch

Signed-off-by: Javier Marcet <javier@marcet.info>
pull/25062/merge
Javier Marcet 2024-06-24 17:32:10 +02:00 committed by Rosen Penev
parent 8fca946384
commit c488c16c82
2 changed files with 32 additions and 1 deletions

View File

@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=reschroot
PKG_VERSION:=1.6.13
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeberg.org/shelter/reschroot/archive/release

View File

@ -0,0 +1,31 @@
--- a/sbuild/sbuild-chroot-config.cc
+++ b/sbuild/sbuild-chroot-config.cc
@@ -31,6 +31,7 @@
#include <cstdlib>
#include <cstring>
+#include <boost/filesystem/directory.hpp>
#include <boost/filesystem/operations.hpp>
#include <sys/types.h>
--- a/sbuild/sbuild-run-parts.cc
+++ b/sbuild/sbuild-run-parts.cc
@@ -29,6 +29,7 @@
#include <syslog.h>
#include <boost/format.hpp>
+#include <boost/filesystem/directory.hpp>
#include <boost/filesystem/operations.hpp>
using boost::format;
--- a/sbuild/sbuild-util.cc
+++ b/sbuild/sbuild-util.cc
@@ -35,8 +35,6 @@
#include <time.h>
#endif
-#include <boost/filesystem/convenience.hpp>
-
using namespace sbuild;
namespace