mirror of https://github.com/openwrt/packages.git
mdnsresponder: bump to 567
Signed-off-by: Steven Barth <steven@midlink.org>pull/1068/head
parent
8b13d6af4f
commit
c8c6157e7e
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mDNSResponder
|
||||
PKG_VERSION:=561.1.1
|
||||
PKG_VERSION:=567
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=mDNSResponder-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://opensource.apple.com/tarballs/mDNSResponder/
|
||||
PKG_MD5SUM:=d4b56e22798d6f45e29b42cd6720ab6e
|
||||
PKG_MD5SUM:=6eff6d243a12a3d4b6fca03c05a9893b
|
||||
PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Clients/Makefile
|
||||
+++ b/Clients/Makefile
|
||||
@@ -23,6 +23,8 @@
|
||||
@@ -27,6 +27,8 @@
|
||||
|
||||
#############################################################################
|
||||
|
||||
|
@ -9,22 +9,22 @@
|
|||
# On OS X the dns_sd library functions are included in libSystem, which is implicitly linked with every executable
|
||||
# If /usr/lib/libSystem.dylib exists, then we're on OS X, so we don't need also to link the "dns_sd" shared library
|
||||
ifneq "$(wildcard /usr/lib/libSystem.dylib)" ""
|
||||
@@ -42,10 +44,10 @@ build:
|
||||
@@ -46,10 +48,10 @@ build:
|
||||
mkdir build
|
||||
|
||||
build/dns-sd: build dns-sd.c ClientCommon.c
|
||||
- cc $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@
|
||||
- $(CC) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@
|
||||
+ $(CC) $(CFLAGS) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@
|
||||
|
||||
build/dns-sd64: build dns-sd.c ClientCommon.c
|
||||
- cc $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@ -m64
|
||||
- $(CC) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@ -m64
|
||||
+ $(CC) $(CFLAGS) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@ -m64
|
||||
|
||||
# Note, we can make a 'fat' version of dns-sd using 'lipo', as shown below, but we
|
||||
# don't, because we don't want or need a 'fat' version of dns-sd, because it will
|
||||
--- a/mDNSPosix/Makefile
|
||||
+++ b/mDNSPosix/Makefile
|
||||
@@ -54,10 +54,11 @@ COREDIR = ../mDNSCore
|
||||
@@ -54,11 +54,12 @@ COREDIR = ../mDNSCore
|
||||
SHAREDDIR ?= ../mDNSShared
|
||||
JDK = /usr/jdk
|
||||
|
||||
|
@ -32,22 +32,14 @@
|
|||
+CC = @gcc
|
||||
BISON = @bison
|
||||
FLEX = @flex
|
||||
ST = @strip
|
||||
-LD = ld -shared
|
||||
+LD = @ld
|
||||
+SOOPTS = -shared
|
||||
CP = cp
|
||||
RM = rm
|
||||
LN = ln -s -f
|
||||
@@ -82,7 +83,7 @@ else
|
||||
CFLAGS_DEBUG = -Os -DMDNS_DEBUGMSGS=0
|
||||
OBJDIR ?= objects/prod
|
||||
BUILDDIR ?= build/prod
|
||||
-STRIP = strip -S
|
||||
+STRIP = @strip -S
|
||||
endif
|
||||
|
||||
# Configure per-OS peculiarities
|
||||
@@ -91,7 +92,7 @@ CFLAGS_DEBUG = -O0 -DMDNS_DEBUGMSGS=0
|
||||
@@ -92,7 +93,7 @@ CFLAGS_DEBUG = -O0 -DMDNS_DEBUGMSGS=0
|
||||
CFLAGS_OS = -DNOT_HAVE_DAEMON -DNOT_HAVE_SA_LEN -DNOT_HAVE_SOCKLEN_T -DNOT_HAVE_IF_NAMETOINDEX \
|
||||
-DLOG_PERROR=0 -D_XPG4_2 -D__EXTENSIONS__ -DHAVE_BROKEN_RECVIF_NAME -DTARGET_OS_SOLARIS
|
||||
CC = gcc
|
||||
|
@ -56,7 +48,7 @@
|
|||
LINKOPTS = -lsocket -lnsl -lresolv
|
||||
JAVACFLAGS_OS += -I$(JDK)/include/solaris
|
||||
ifneq ($(DEBUG),1)
|
||||
@@ -147,7 +148,8 @@ CFLAGS_OS = -DHAVE_IPV6 -no-cpp-precomp
|
||||
@@ -148,7 +149,8 @@ CFLAGS_OS = -DHAVE_IPV6 -no-cpp-precomp
|
||||
-D__MAC_OS_X_VERSION_MIN_REQUIRED=__MAC_OS_X_VERSION_10_4 \
|
||||
-D__APPLE_USE_RFC_2292 #-Wunreachable-code
|
||||
CC = gcc
|
||||
|
@ -66,7 +58,7 @@
|
|||
LINKOPTS = -lSystem
|
||||
LDSUFFIX = dylib
|
||||
JDK = /System/Library/Frameworks/JavaVM.framework/Home
|
||||
@@ -169,8 +171,9 @@ NSSLIBFILE := $(NSSLIBNAME)-$(NSSVERSIO
|
||||
@@ -170,8 +172,9 @@ NSSLIBFILE := $(NSSLIBNAME)-$(NSSVERSIO
|
||||
NSSLINKNAME := $(NSSLIBNAME).so.2
|
||||
NSSINSTPATH := /lib
|
||||
|
||||
|
@ -77,7 +69,7 @@
|
|||
INSTBASE?=/usr
|
||||
STARTUPSCRIPTNAME?=mdns
|
||||
|
||||
@@ -256,7 +259,7 @@ libdns_sd: setup $(BUILDDIR)/libdns_sd.$
|
||||
@@ -257,7 +260,7 @@ libdns_sd: setup $(BUILDDIR)/libdns_sd.$
|
||||
CLIENTLIBOBJS = $(OBJDIR)/dnssd_clientlib.c.so.o $(OBJDIR)/dnssd_clientstub.c.so.o $(OBJDIR)/dnssd_ipc.c.so.o
|
||||
|
||||
$(BUILDDIR)/libdns_sd.$(LDSUFFIX): $(CLIENTLIBOBJS)
|
||||
|
@ -86,7 +78,7 @@
|
|||
@$(STRIP) $@
|
||||
|
||||
Clients: setup libdns_sd ../Clients/build/dns-sd
|
||||
@@ -291,7 +294,7 @@ InstalledManPages: $(MANPATH)/man8/mdnsd
|
||||
@@ -292,7 +295,7 @@ InstalledManPages: $(MANPATH)/man8/mdnsd
|
||||
InstalledClients: $(INSTBASE)/bin/dns-sd
|
||||
@echo $+ " installed"
|
||||
|
||||
|
@ -95,7 +87,7 @@
|
|||
@echo $+ " installed"
|
||||
|
||||
# Note: If daemon already installed, we make sure it's stopped before overwriting it
|
||||
@@ -346,19 +349,21 @@ $(INSTBASE)/bin/dns-sd: ../Clients/build
|
||||
@@ -347,19 +350,21 @@ $(INSTBASE)/bin/dns-sd: ../Clients/build
|
||||
|
||||
$(NSSINSTPATH)/$(NSSLINKNAME): $(NSSINSTPATH)/$(NSSLIBFILE)
|
||||
$(LN) $< $@
|
||||
|
|
|
@ -84,7 +84,7 @@
|
|||
}
|
||||
--- a/mDNSPosix/mDNSPosix.c
|
||||
+++ b/mDNSPosix/mDNSPosix.c
|
||||
@@ -136,7 +136,7 @@ mDNSlocal void SockAddrTomDNSAddr(const
|
||||
@@ -138,7 +138,7 @@ mDNSlocal void SockAddrTomDNSAddr(const
|
||||
|
||||
// mDNS core calls this routine when it needs to send a packet.
|
||||
mDNSexport mStatus mDNSPlatformSendUDP(const mDNS *const m, const void *const msg, const mDNSu8 *const end,
|
||||
|
@ -93,7 +93,7 @@
|
|||
mDNSIPPort dstPort, mDNSBool useBackgroundTrafficClass)
|
||||
{
|
||||
int err = 0;
|
||||
@@ -574,9 +574,17 @@ mDNSlocal void FreePosixNetworkInterface
|
||||
@@ -583,9 +583,17 @@ mDNSlocal void FreePosixNetworkInterface
|
||||
{
|
||||
assert(intf != NULL);
|
||||
if (intf->intfName != NULL) free((void *)intf->intfName);
|
||||
|
@ -111,9 +111,9 @@
|
|||
+ assert(rv == 0);
|
||||
+ }
|
||||
#endif
|
||||
free(intf);
|
||||
}
|
||||
@@ -703,6 +711,29 @@ mDNSlocal int SetupSocket(struct sockadd
|
||||
|
||||
// Move interface to the RecentInterfaces list for a minute
|
||||
@@ -724,6 +732,29 @@ mDNSlocal int SetupSocket(struct sockadd
|
||||
if (err < 0) { err = errno; perror("setsockopt - IP_MULTICAST_TTL"); }
|
||||
}
|
||||
|
||||
|
@ -143,7 +143,7 @@
|
|||
// And start listening for packets
|
||||
if (err == 0)
|
||||
{
|
||||
@@ -784,6 +815,29 @@ mDNSlocal int SetupSocket(struct sockadd
|
||||
@@ -805,6 +836,29 @@ mDNSlocal int SetupSocket(struct sockadd
|
||||
if (err < 0) { err = errno; perror("setsockopt - IPV6_MULTICAST_HOPS"); }
|
||||
}
|
||||
|
||||
|
@ -173,7 +173,7 @@
|
|||
// And start listening for packets
|
||||
if (err == 0)
|
||||
{
|
||||
@@ -815,7 +869,12 @@ mDNSlocal int SetupSocket(struct sockadd
|
||||
@@ -836,7 +890,12 @@ mDNSlocal int SetupSocket(struct sockadd
|
||||
}
|
||||
|
||||
// Clean up
|
||||
|
@ -187,7 +187,7 @@
|
|||
assert((err == 0) == (*sktPtr != -1));
|
||||
return err;
|
||||
}
|
||||
@@ -994,7 +1053,7 @@ mDNSlocal mStatus OpenIfNotifySocket(int
|
||||
@@ -1026,7 +1085,7 @@ mDNSlocal mStatus OpenIfNotifySocket(int
|
||||
/* Subscribe the socket to Link & IP addr notifications. */
|
||||
mDNSPlatformMemZero(&snl, sizeof snl);
|
||||
snl.nl_family = AF_NETLINK;
|
||||
|
@ -196,7 +196,7 @@
|
|||
ret = bind(sock, (struct sockaddr *) &snl, sizeof snl);
|
||||
if (0 == ret)
|
||||
*pFD = sock;
|
||||
@@ -1072,11 +1131,18 @@ mDNSlocal mDNSu32 ProcessRoutingNo
|
||||
@@ -1104,11 +1163,18 @@ mDNSlocal mDNSu32 ProcessRoutingNo
|
||||
PrintNetLinkMsg(pNLMsg);
|
||||
#endif
|
||||
|
||||
|
@ -217,7 +217,7 @@
|
|||
|
||||
// Advance pNLMsg to the next message in the buffer
|
||||
if ((pNLMsg->nlmsg_flags & NLM_F_MULTI) != 0 && pNLMsg->nlmsg_type != NLMSG_DONE)
|
||||
@@ -1247,8 +1313,12 @@ mDNSexport mStatus mDNSPlatformInit(mDNS
|
||||
@@ -1279,8 +1345,12 @@ mDNSexport mStatus mDNSPlatformInit(mDNS
|
||||
if (err == mStatus_NoError) err = SetupSocket(&sa, zeroIPPort, 0, &m->p->unicastSocket6);
|
||||
#endif
|
||||
|
||||
|
@ -230,7 +230,7 @@
|
|||
|
||||
// Tell mDNS core about DNS Servers
|
||||
mDNS_Lock(m);
|
||||
@@ -1281,9 +1351,17 @@ mDNSexport void mDNSPlatformClose(mDNS *
|
||||
@@ -1313,9 +1383,17 @@ mDNSexport void mDNSPlatformClose(mDNS *
|
||||
{
|
||||
assert(m != NULL);
|
||||
ClearInterfaceList(m);
|
||||
|
@ -250,7 +250,7 @@
|
|||
#endif
|
||||
}
|
||||
|
||||
@@ -1533,14 +1611,14 @@ mDNSexport mStatus mDNSPlatformClearS
|
||||
@@ -1571,14 +1649,14 @@ mDNSexport mStatus mDNSPlatformClearS
|
||||
mDNSexport mDNSu16 mDNSPlatformGetUDPPort(UDPSocket *sock)
|
||||
{
|
||||
(void) sock; // unused
|
||||
|
|
Loading…
Reference in New Issue