mirror of https://github.com/openwrt/packages.git
znc: Update to 1.7.1
Notable Changes: * New IRCv3.2 capabilities support on client and server side * Increased max line lengths * support for stripping color control codes * various bug fixes Signed-off-by: Rosen Penev <rosenp@gmail.com> [jonas.gorski: add notable changes, switch to 1.7.1] Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>pull/6596/head
parent
57c8664b31
commit
cb202c0acb
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=znc
|
||||
PKG_VERSION:=1.6.6
|
||||
PKG_VERSION:=1.7.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://znc.in/releases \
|
||||
https://znc.in/releases/archive
|
||||
PKG_HASH:=7fb841bc71dc1749b1dc081e9eaf22ceb56ebb03c6b1d8804a4f9eb8bbd59525
|
||||
PKG_HASH:=44cfea7158ea05dc2547c7c6bc22371e66c869def90351de0ab90a9c200d39c4
|
||||
|
||||
PKG_MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
|
@ -277,27 +277,23 @@ $(eval $(call webskin,ice))
|
|||
PKG_CONFIG_DEPENDS += $(patsubst %,CONFIG_PACKAGE_%,$(ZNC_MODULES))
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
|
||||
CMAKE_OPTIONS += $(if $(CONFIG_ZNC_ICU), WANT_ICU=TRUE, WANT_ICU=FALSE) \
|
||||
WANT_CYRUS=FALSE \
|
||||
WANT_PERL=FALSE \
|
||||
WANT_PYTHON=FALSE \
|
||||
WANT_SWIG=FALSE \
|
||||
WANT_TCL=FALSE \
|
||||
WANT_OPENSSL=TRUE \
|
||||
WANT_ZLIB=TRUE
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti" \
|
||||
CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-nodefaultlibs -lc -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
LIBS="-lstdc++ -lm -lssl -lcrypto $(LIBGCC_S) -lc"
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
$(if $(CONFIG_ZNC_ICU), --enable-charset, --disable-charset) \
|
||||
--disable-cyrus \
|
||||
--disable-debug \
|
||||
--enable-largefile \
|
||||
--disable-perl \
|
||||
--enable-poll \
|
||||
--disable-python \
|
||||
--enable-ssl \
|
||||
--disable-swig \
|
||||
--disable-tcl \
|
||||
--enable-tdns \
|
||||
--enable-zlib
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default,)
|
||||
$(call libtool_disable_rpath)
|
||||
|
|
|
@ -1,52 +1,52 @@
|
|||
From adf42357c9043c38d9a9b47544a1b46445bdae19 Mon Sep 17 00:00:00 2001
|
||||
From: Jonas Gorski <jonas.gorski+openwrt@gmail.com>
|
||||
Date: Wed, 6 Apr 2011 04:10:23 +0200
|
||||
Subject: [PATCH] Move the root check to after config parsing
|
||||
|
||||
---
|
||||
src/main.cpp | 27 ++++++++++++++-------------
|
||||
1 file changed, 14 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/src/main.cpp b/src/main.cpp
|
||||
index 6ea10ec..0bf028b 100644
|
||||
--- a/src/main.cpp
|
||||
+++ b/src/main.cpp
|
||||
@@ -312,19 +312,6 @@ int main(int argc, char** argv) {
|
||||
CUtils::PrintStatus(true, "");
|
||||
}
|
||||
@@ -422,23 +422,6 @@ int main(int argc, char** argv) {
|
||||
CUtils::PrintStatus(true, "");
|
||||
}
|
||||
|
||||
- if (isRoot()) {
|
||||
- CUtils::PrintError("You are running ZNC as root! Don't do that! There are not many valid");
|
||||
- CUtils::PrintError("reasons for this and it can, in theory, cause great damage!");
|
||||
- if (!bAllowRoot) {
|
||||
- CZNC::DestroyInstance();
|
||||
- return 1;
|
||||
- }
|
||||
- CUtils::PrintError("You have been warned.");
|
||||
- CUtils::PrintError("Hit CTRL+C now if you don't want to run ZNC as root.");
|
||||
- CUtils::PrintError("ZNC will start in 30 seconds.");
|
||||
- sleep(30);
|
||||
- }
|
||||
- if (isRoot()) {
|
||||
- CUtils::PrintError(
|
||||
- "You are running ZNC as root! Don't do that! There are not many "
|
||||
- "valid");
|
||||
- CUtils::PrintError(
|
||||
- "reasons for this and it can, in theory, cause great damage!");
|
||||
- if (!bAllowRoot) {
|
||||
- CZNC::DestroyInstance();
|
||||
- return 1;
|
||||
- }
|
||||
- CUtils::PrintError("You have been warned.");
|
||||
- CUtils::PrintError(
|
||||
- "Hit CTRL+C now if you don't want to run ZNC as root.");
|
||||
- CUtils::PrintError("ZNC will start in 30 seconds.");
|
||||
- sleep(30);
|
||||
- }
|
||||
-
|
||||
if (bMakeConf) {
|
||||
if (!pZNC->WriteNewConfig(sConfig)) {
|
||||
CZNC::DestroyInstance();
|
||||
@@ -346,6 +333,20 @@ int main(int argc, char** argv) {
|
||||
return 1;
|
||||
}
|
||||
if (bMakeConf) {
|
||||
if (!pZNC->WriteNewConfig(sConfig)) {
|
||||
CZNC::DestroyInstance();
|
||||
@@ -460,6 +443,23 @@ int main(int argc, char** argv) {
|
||||
return 1;
|
||||
}
|
||||
|
||||
+ if (isRoot()) {
|
||||
+ CUtils::PrintError("You are running ZNC as root! Don't do that! There are not many valid");
|
||||
+ CUtils::PrintError("reasons for this and it can, in theory, cause great damage!");
|
||||
+ if (!bAllowRoot) {
|
||||
+ CZNC::DestroyInstance();
|
||||
+ return 1;
|
||||
+ }
|
||||
+ CUtils::PrintError("You have been warned.");
|
||||
+ CUtils::PrintError("Hit CTRL+C now if you don't want to run ZNC as root.");
|
||||
+ CUtils::PrintError("ZNC will start in 30 seconds.");
|
||||
+ sleep(30);
|
||||
+ }
|
||||
+ if (isRoot()) {
|
||||
+ CUtils::PrintError(
|
||||
+ "You are running ZNC as root! Don't do that! There are not many "
|
||||
+ "valid");
|
||||
+ CUtils::PrintError(
|
||||
+ "reasons for this and it can, in theory, cause great damage!");
|
||||
+ if (!bAllowRoot) {
|
||||
+ CZNC::DestroyInstance();
|
||||
+ return 1;
|
||||
+ }
|
||||
+ CUtils::PrintError("You have been warned.");
|
||||
+ CUtils::PrintError(
|
||||
+ "Hit CTRL+C now if you don't want to run ZNC as root.");
|
||||
+ CUtils::PrintError("ZNC will start in 30 seconds.");
|
||||
+ sleep(30);
|
||||
+ }
|
||||
+
|
||||
+
|
||||
if (bForeground) {
|
||||
int iPid = getpid();
|
||||
CUtils::PrintMessage("Staying open for debugging [pid: " + CString(iPid) + "]");
|
||||
if (bForeground) {
|
||||
int iPid = getpid();
|
||||
CUtils::PrintMessage("Staying open for debugging [pid: " +
|
||||
|
|
|
@ -11,7 +11,7 @@ Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp
|
|||
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -112,7 +112,7 @@ clean:
|
||||
@@ -128,7 +128,7 @@ clean:
|
||||
distclean: clean
|
||||
rm -rf $(DISTCLEAN)
|
||||
|
||||
|
@ -22,7 +22,7 @@ Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp
|
|||
$(Q)$(CXX) $(CXXFLAGS) -c -o $@ $< -MD -MF .depend/$*.dep -MT $@
|
||||
--- a/modules/Makefile.in
|
||||
+++ b/modules/Makefile.in
|
||||
@@ -112,12 +112,12 @@ install_datadir:
|
||||
@@ -127,12 +127,12 @@ install_datadir:
|
||||
clean:
|
||||
rm -rf $(CLEAN)
|
||||
|
||||
|
|
|
@ -1,15 +1,17 @@
|
|||
--- a/src/main.cpp
|
||||
+++ b/src/main.cpp
|
||||
@@ -304,10 +304,12 @@ int main(int argc, char** argv) {
|
||||
CUtils::PrintStatus(false, "");
|
||||
CUtils::PrintError("No modules found. Perhaps you didn't install ZNC properly?");
|
||||
CUtils::PrintError("Read http://wiki.znc.in/Installation for instructions.");
|
||||
@@ -412,12 +412,14 @@ int main(int argc, char** argv) {
|
||||
"No modules found. Perhaps you didn't install ZNC properly?");
|
||||
CUtils::PrintError(
|
||||
"Read https://wiki.znc.in/Installation for instructions.");
|
||||
+#if 0
|
||||
if (!CUtils::GetBoolInput("Do you really want to run ZNC without any modules?", false)) {
|
||||
CZNC::DestroyInstance();
|
||||
return 1;
|
||||
}
|
||||
if (!CUtils::GetBoolInput(
|
||||
"Do you really want to run ZNC without any modules?",
|
||||
false)) {
|
||||
CZNC::DestroyInstance();
|
||||
return 1;
|
||||
}
|
||||
+#endif
|
||||
}
|
||||
CUtils::PrintStatus(true, "");
|
||||
}
|
||||
}
|
||||
CUtils::PrintStatus(true, "");
|
||||
}
|
||||
|
|
Loading…
Reference in New Issue