tgt: update to 1.0.92

refresh patches and build flags according to the upstream changes

Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
pull/24398/head
Maxim Storchak 2024-06-15 15:52:35 +03:00 committed by Tianling Shen
parent 78113e13ef
commit d5ed8575e5
3 changed files with 4 additions and 34 deletions

View File

@ -4,12 +4,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=tgt
PKG_VERSION:=1.0.91
PKG_VERSION:=1.0.92
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/fujita/tgt/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=3bfd50e19f308e9d197e2f6877fb5d13e4777e5bbb61716a7409b3735b481d8f
PKG_HASH:=06721dcdb88bcc13721bf5de92b57e84a208e04084f8ed937c3ecade6459662f
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
PKG_LICENSE:=GPL-2.0-only
@ -35,10 +35,6 @@ supports multiple methods for accessing block storage. Tgt consists of
user-space daemon and tools.
endef
ifneq ($(CONFIG_USE_MUSL),)
TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
endif
define Build/Compile
$(call Build/Compile/Default,programs)
endef

View File

@ -23,7 +23,7 @@
CFLAGS += -DUSE_EVENTFD
TGTD_OBJS += bs_aio.o
LIBS += -laio
@@ -55,7 +55,7 @@ ifneq ($(SD_NOTIFY),)
@@ -56,7 +56,7 @@ ifneq ($(SD_NOTIFY),)
LIBS += -lsystemd
endif
@ -32,7 +32,7 @@
TGTD_OBJS += tgtd.o mgmt.o target.o scsi.o log.o driver.o util.o work.o \
concat_buf.o parser.o spc.o sbc.o mmc.o osd.o scc.o smc.o \
ssc.o libssc.o bs_rdwr.o bs_ssc.o \
@@ -82,14 +82,6 @@ tgtadm: $(TGTADM_OBJS)
@@ -83,14 +83,6 @@ tgtadm: $(TGTADM_OBJS)
-include $(TGTADM_DEP)

View File

@ -1,26 +0,0 @@
--- a/usr/tgtd.h
+++ b/usr/tgtd.h
@@ -9,6 +9,10 @@
#include <systemd/sd-daemon.h>
#endif
+#ifndef __WORDSIZE
+#include <sys/reg.h>
+#endif
+
struct concat_buf;
#define NR_SCSI_OPCODES 256
--- a/usr/util.h
+++ b/usr/util.h
@@ -21,6 +21,10 @@
#include <sys/stat.h>
#include <sys/types.h>
+#ifndef __WORDSIZE
+#include <sys/reg.h>
+#endif
+
#include "be_byteshift.h"
#define roundup(x, y) ((((x) + ((y) - 1)) / (y)) * (y))