mirror of https://github.com/openwrt/packages.git
tayga: fix compilation with GCC14
Header is needed for musl. Signed-off-by: Rosen Penev <rosenp@gmail.com>pull/25413/head
parent
824b2c09a0
commit
db51a6426c
|
@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=tayga
|
||||
PKG_VERSION:=0.9.2
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE:=tayga-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.litech.org/tayga/
|
||||
|
|
|
@ -0,0 +1,10 @@
|
|||
--- a/tayga.h
|
||||
+++ b/tayga.h
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <sys/stat.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/socket.h>
|
||||
+#include <sys/uio.h>
|
||||
#include <netinet/in.h>
|
||||
#include <arpa/inet.h>
|
||||
#include <unistd.h>
|
Loading…
Reference in New Issue