tayga: fix compilation with GCC14

Header is needed for musl.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
pull/25413/head
Rosen Penev 2024-11-11 16:30:48 -08:00
parent 824b2c09a0
commit db51a6426c
2 changed files with 11 additions and 1 deletions

View File

@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tayga
PKG_VERSION:=0.9.2
PKG_RELEASE:=4
PKG_RELEASE:=5
PKG_SOURCE:=tayga-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.litech.org/tayga/

View File

@ -0,0 +1,10 @@
--- a/tayga.h
+++ b/tayga.h
@@ -20,6 +20,7 @@
#include <sys/stat.h>
#include <sys/ioctl.h>
#include <sys/socket.h>
+#include <sys/uio.h>
#include <netinet/in.h>
#include <arpa/inet.h>
#include <unistd.h>