mirror of https://github.com/openwrt/packages.git
mmc-utils: fix compilation on mips64
This commit adds a patch to remove a superfluous include. Removing this include prevents the following error (detected by LEDE project's buildbot while compiling for mips64 architecture): (Note: directory names shorted for better readability) In file included from mmc.h:20:0, from mmc_cmds.c:37: /srv/.../include/asm-generic/int-ll64.h:29:44: error: conflicting types for '__s64' __extension__ typedef __signed__ long long __s64; ^ In file included from /srv/.../include/asm/types.h:22:0, from /srv/.../include/linux/types.h:4, from /srv/.../include/linux/fs.h:11, from mmc_cmds.c:35: /srv/.../include/asm-generic/int-l64.h:28:25: note: previous declaration of '__s64' was here typedef __signed__ long __s64; ^ In file included from mmc.h:20:0, from mmc_cmds.c:37: /srv/.../include/asm-generic/int-ll64.h:30:42: error: conflicting types for '__u64' __extension__ typedef unsigned long long __u64; ^ In file included from /srv/.../include/asm/types.h:22:0, from /srv/.../include/linux/types.h:4, from /srv/.../include/linux/fs.h:11, from mmc_cmds.c:35: /srv/.../include/asm-generic/int-l64.h:29:23: note: previous declaration of '__u64' was here typedef unsigned long __u64; ^ Makefile:36: recipe for target 'mmc_cmds.o' failed The patch was already sent upstream, no response yet. Signed-off-by: Michael Heimpold <mhei@heimpold.de>pull/3225/merge
parent
c68a3f94d4
commit
e7b11e0366
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=mmc-utils
|
||||
PKG_VERSION=2016-09-11-$(PKG_SOURCE_VERSION)
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git
|
||||
|
|
|
@ -0,0 +1,12 @@
|
|||
Sent already upstream, no response yet.
|
||||
|
||||
--- a/mmc.h 2016-09-11 18:01:53.000000000 +0200
|
||||
+++ b/mmc.h 2016-09-23 23:41:02.462632858 +0200
|
||||
@@ -17,7 +17,6 @@
|
||||
* those modifications are Copyright (c) 2016 SanDisk Corp.
|
||||
*/
|
||||
|
||||
-#include <asm-generic/int-ll64.h>
|
||||
#include <linux/mmc/ioctl.h>
|
||||
#include <stdio.h>
|
||||
|
Loading…
Reference in New Issue