kea: update to 2.6.0

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
pull/24736/head
Philip Prindeville 2024-07-29 21:18:01 -06:00 committed by Rosen Penev
parent 2664e85a64
commit ee1df08108
4 changed files with 26 additions and 19 deletions

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=kea
PKG_VERSION:=2.4.0
PKG_VERSION:=2.6.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://ftp.isc.org/isc/kea/$(PKG_VERSION)
PKG_HASH:=3a33cd08dc3319ff544e6bbf2c0429042106f4051ebe115dc1bb2625c95003f7
PKG_HASH:=207ceae33eb3b81ec4e6ac5605249a85b93779333b62aadf39e489f11dbcdc8d
PKG_MAINTAINER:=BangLang Huang <banglang.huang@foxmail.com>, Rosy Song <rosysong@rosinson.com>
PKG_LICENSE:=MPL-2.0

View File

@ -116,7 +116,7 @@
-SUBDIRS = . tests
+SUBDIRS = .
AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
AM_CPPFLAGS += $(BOOST_INCLUDES)
--- a/src/lib/asiolink/Makefile.am
+++ b/src/lib/asiolink/Makefile.am
@ -169,7 +169,7 @@
--- a/src/lib/dhcp/Makefile.am
+++ b/src/lib/dhcp/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = . tests
-SUBDIRS = . testutils tests
+SUBDIRS = .
AM_CPPFLAGS = -I$(top_builddir)/src/lib -I$(top_srcdir)/src/lib
@ -256,16 +256,16 @@
-SUBDIRS = . testutils tests
+SUBDIRS = .
AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
AM_CPPFLAGS += $(BOOST_INCLUDES) $(MYSQL_CPPFLAGS)
AM_CPPFLAGS =
AM_CPPFLAGS += -DKEA_ADMIN=\"@prefix@/sbin/kea-admin\"
--- a/src/lib/pgsql/Makefile.am
+++ b/src/lib/pgsql/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = . testutils tests
+SUBDIRS = .
AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
AM_CPPFLAGS += $(BOOST_INCLUDES) $(PGSQL_CPPFLAGS)
AM_CPPFLAGS =
AM_CPPFLAGS += -DKEA_ADMIN=\"@prefix@/sbin/kea-admin\"
--- a/src/lib/process/Makefile.am
+++ b/src/lib/process/Makefile.am
@@ -1,4 +1,4 @@

View File

@ -1,11 +0,0 @@
--- a/src/bin/keactrl/keactrl.in
+++ b/src/bin/keactrl/keactrl.in
@@ -115,7 +115,7 @@ get_pid_from_file() {
# Extract the name portion (from last slash to last dot) of the config file name
# File name and extension are documented in src/lib/util/filename.h
local conf_name
- conf_name=$(basename -- "${kea_config_file}" | rev | cut -f2- -d'.' | rev)
+ conf_name=$(basename -- "${kea_config_file}" | awk '{for(i=length($0); i>0;i--) printf (substr($0,i,1));}' | cut -f2- -d'.' | awk '{for(i=length($0); i>0;i--) printf (substr($0,i,1));}')
# Default the directory to --localstatedir / run
local pid_file_dir

View File

@ -0,0 +1,18 @@
commit 79f969979f2ac7ed73dbc2682a53c95ff84adb1a
Author: Philip Prindeville <philipp@redfish-solutions.com>
Date: Sat Aug 3 10:19:05 2024 -0600
[3533] do filename munging with variable expansions
--- a/src/bin/keactrl/keactrl.in
+++ b/src/bin/keactrl/keactrl.in
@@ -112,7 +112,8 @@ get_pid_from_file() {
# Extract the name portion (from last slash to last dot) of the config file name.
local conf_name
- conf_name=$(basename -- "${kea_config_file}" | rev | cut -f2- -d'.' | rev)
+ conf_name=${kea_config_file##*/}
+ conf_name=${conf_name%.*}
# Default the directory to --localstatedir / run
local pid_file_dir