mirror of https://github.com/openwrt/packages.git
tdb: bump to latest version
Signed-off-by: BangLang Huang <banglang.huang@foxmail.com>pull/4703/head
parent
d4ed4c1f21
commit
f06373a547
|
@ -8,18 +8,22 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=tdb
|
||||
PKG_VERSION:=1.0.6
|
||||
PKG_VERSION:=1.3.14
|
||||
PKG_RELEASE:=1
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/tdb
|
||||
PKG_MD5SUM:=6b643fdeb48304010dcd5f675e458b58
|
||||
PKG_SOURCE_URL:=https://www.samba.org/ftp/tdb/
|
||||
PKG_HASH:=3a7d4bb79229460df530c7e1c7067ba9fb9d370aa61fff537fdc2bdf918acbe9
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_DEPENDS:=+libgdbm
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
# for $(LINUX_VERSION)
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
# for $(VERSION_DIST)
|
||||
include $(INCLUDE_DIR)/version.mk
|
||||
#include $(INCLUDE_DIR)/version.mk
|
||||
|
||||
define Package/tdb
|
||||
SUBMENU:=database
|
||||
|
@ -28,7 +32,6 @@ define Package/tdb
|
|||
TITLE:=Trivial Database
|
||||
URL:=http://sourceforge.net/projects/tdb/
|
||||
MAINTAINER:=Dmitry V. Zimin <pfzim@mail.ru>
|
||||
# DEPENDS:=+libgdbm
|
||||
endef
|
||||
|
||||
define Package/tdb/description
|
||||
|
@ -45,9 +48,42 @@ define Build/InstallDev
|
|||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS = \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--cross-compile \
|
||||
--cross-answers="$(PKG_BUILD_DIR)/cache.txt" \
|
||||
--program-prefix="" \
|
||||
--prefix=$(CONFIGURE_PREFIX) \
|
||||
--exec-prefix=$(CONFIGURE_PREFIX) \
|
||||
--bindir=$(CONFIGURE_PREFIX)/bin \
|
||||
--sbindir=$(CONFIGURE_PREFIX)/sbin \
|
||||
--libexecdir=$(CONFIGURE_PREFIX)/lib \
|
||||
--sysconfdir=/etc \
|
||||
--datadir=$(CONFIGURE_PREFIX)/share \
|
||||
--localstatedir=/var \
|
||||
--mandir=$(CONFIGURE_PREFIX)/man \
|
||||
--infodir=$(CONFIGURE_PREFIX)/info \
|
||||
$(DISABLE_IPV6)
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-python \
|
||||
--disable-rpath \
|
||||
--disable-rpath-install \
|
||||
--disable-rpath-private-install
|
||||
|
||||
define Build/Configure
|
||||
$(CP) ./files/tdb.cache.txt $(PKG_BUILD_DIR)/cache.txt
|
||||
echo -e "\nChecking uname sysname type: \"$(VERSION_DIST)\" \
|
||||
\nChecking uname release type: \"$(LINUX_VERSION)-$(GNU_TARGET_NAME)\" \
|
||||
\nChecking uname machine type: \"$(ARCH)\" \
|
||||
\nChecking uname version type: \"$(VERSION_DIST) Linux-$(LINUX_VERSION) $(shell date +%Y-%m-%d)\"\n" >> $(PKG_BUILD_DIR)/cache.txt;
|
||||
$(call Build/Configure/Default)
|
||||
endef
|
||||
|
||||
define Package/tdb/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
|
||||
endef
|
||||
|
|
|
@ -0,0 +1,36 @@
|
|||
Checking simple C program: OK
|
||||
rpath library support: OK
|
||||
-Wl,--version-script support: OK
|
||||
Checking getconf LFS_CFLAGS: NO
|
||||
Checking for large file support without additional flags: OK
|
||||
Checking for -D_LARGE_FILES: OK
|
||||
Checking correct behavior of strtoll: NO
|
||||
Checking for working strptime: OK
|
||||
Checking for C99 vsnprintf: OK
|
||||
Checking for HAVE_SHARED_MMAP: OK
|
||||
Checking for HAVE_MREMAP: OK
|
||||
Checking for HAVE_INCOHERENT_MMAP: NO
|
||||
Checking for HAVE_SECURE_MKSTEMP: OK
|
||||
Checking for HAVE_IFACE_GETIFADDRS: OK
|
||||
Checking for kernel change notify support: OK
|
||||
Checking for Linux kernel oplocks: OK
|
||||
Checking for kernel share modes: OK
|
||||
Checking if can we convert from CP850 to UCS-2LE: OK
|
||||
Checking if can we convert from UTF-8 to UCS-2LE: OK
|
||||
Checking whether we can use Linux thread-specific credentials with 32-bit system calls: OK
|
||||
Checking whether we can use Linux thread-specific credentials: OK
|
||||
Checking whether setreuid is available: OK
|
||||
Checking whether setresuid is available: OK
|
||||
Checking whether seteuid is available: OK
|
||||
Checking whether fcntl locking is available: OK
|
||||
Checking whether fcntl lock supports open file description locks: OK
|
||||
Checking for the maximum value of the 'time_t' type: OK
|
||||
Checking whether the realpath function allows a NULL argument: OK
|
||||
Checking whether POSIX capabilities are available: OK
|
||||
Checking for ftruncate extend: OK
|
||||
vfs_fileid checking for statfs() and struct statfs.f_fsid: OK
|
||||
getcwd takes a NULL argument: OK
|
||||
Checking value of NSIG: "65"
|
||||
Checking value of _NSIG: "65"
|
||||
Checking value of SIGRTMAX: "64"
|
||||
Checking value of SIGRTMIN: "34"
|
|
@ -1,41 +0,0 @@
|
|||
--- a/tdbtool.c 2001-12-11 06:45:47.000000000 +0300
|
||||
+++ b/tdbtool.c 2014-11-14 15:14:00.401164300 +0300
|
||||
@@ -169,23 +169,21 @@ static void print_data(unsigned char *bu
|
||||
|
||||
static void help(void)
|
||||
{
|
||||
- printf("
|
||||
-tdbtool:
|
||||
- create dbname : create a database
|
||||
- open dbname : open an existing database
|
||||
- erase : erase the database
|
||||
- dump dumpname : dump the database as strings
|
||||
- insert key data : insert a record
|
||||
- store key data : store a record (replace)
|
||||
- show key : show a record by key
|
||||
- delete key : delete a record by key
|
||||
- list : print the database hash table and freelist
|
||||
- free : print the database freelist
|
||||
- 1 | first : print the first record
|
||||
- n | next : print the next record
|
||||
- q | quit : terminate
|
||||
- \\n : repeat 'next' command
|
||||
-");
|
||||
+ printf("tdbtool:\n");
|
||||
+ printf(" create dbname : create a database\n");
|
||||
+ printf(" open dbname : open an existing database\n");
|
||||
+ printf(" erase : erase the database\n");
|
||||
+ printf(" dump dumpname : dump the database as strings\n");
|
||||
+ printf(" insert key data : insert a record\n");
|
||||
+ printf(" store key data : store a record (replace)\n");
|
||||
+ printf(" show key : show a record by key\n");
|
||||
+ printf(" delete key : delete a record by key\n");
|
||||
+ printf(" list : print the database hash table and freelist\n");
|
||||
+ printf(" free : print the database freelist\n");
|
||||
+ printf(" 1 | first : print the first record\n");
|
||||
+ printf(" n | next : print the next record\n");
|
||||
+ printf(" q | quit : terminate\n");
|
||||
+ printf(" \\n : repeat 'next' command\n\n");
|
||||
}
|
||||
|
||||
static void terror(char *why)
|
Loading…
Reference in New Issue