mirror of https://github.com/openwrt/packages.git
tcsh: fix compilation with GCC10
Signed-off-by: Rosen Penev <rosenp@gmail.com>pull/12693/head
parent
820022650f
commit
f86e3a0a9f
|
@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=tcsh
|
||||
PKG_VERSION:=6.22.02
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:= \
|
||||
|
|
|
@ -0,0 +1,22 @@
|
|||
From 6974bc35a5cda6eab748e364bd76a860ca66968b Mon Sep 17 00:00:00 2001
|
||||
From: zoulasc <christos@zoulas.com>
|
||||
Date: Sat, 11 Jan 2020 11:16:51 -0500
|
||||
Subject: [PATCH] Remove extra variable definition that cause -fno-common build
|
||||
to fail (Werner Fink)
|
||||
|
||||
---
|
||||
tc.sig.c | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/tc.sig.c b/tc.sig.c
|
||||
index 77659ca..576605a 100644
|
||||
--- a/tc.sig.c
|
||||
+++ b/tc.sig.c
|
||||
@@ -56,7 +56,6 @@ int alrmcatch_disabled; /* = 0; */
|
||||
int phup_disabled; /* = 0; */
|
||||
int pchild_disabled; /* = 0; */
|
||||
int pintr_disabled; /* = 0; */
|
||||
-int handle_interrupt; /* = 0; */
|
||||
|
||||
int
|
||||
handle_pending_signals(void)
|
Loading…
Reference in New Issue