mirror of https://github.com/openwrt/packages.git
package apache: upgrade to 2.4.25
- refresh patches Signed-off-by: heil <heil@terminal-consulting.de>pull/3707/head
parent
c785ad365c
commit
f8b42ce2c9
|
@ -8,15 +8,15 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=apache
|
||||
PKG_VERSION:=2.2.31
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.4.25
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE_NAME:=httpd
|
||||
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
|
||||
PKG_LICENSE:=Apache License
|
||||
|
||||
PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@APACHE/httpd/
|
||||
PKG_MD5SUM:=6c10e15835ab214464228a9beb7afba8
|
||||
PKG_MD5SUM:=2826f49619112ad5813c0be5afcc7ddb
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_NAME)-$(PKG_VERSION)
|
||||
|
||||
|
@ -90,6 +90,7 @@ endef
|
|||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
|
||||
TARGET_LDFLAGS += -lpthread
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
|
@ -97,16 +98,22 @@ define Build/Configure
|
|||
--with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \
|
||||
--with-pcre="$(STAGING_DIR)/usr/bin/pcre-config" \
|
||||
--enable-http \
|
||||
--with-crypto \
|
||||
--with-sqlit3="$(STAGING_DIR)/usr" \
|
||||
--with-openssl="$(STAGING_DIR)/usr" \
|
||||
--enable-ssl \
|
||||
--enable-proxy \
|
||||
--disable-disk-cache \
|
||||
--enable-maintainer-mode \
|
||||
--with-mpm=prefork \
|
||||
--with-mpm=worker \
|
||||
--enable-mime-magic \
|
||||
--without-suexec-bin \
|
||||
--sysconfdir=/etc/apache \
|
||||
ap_cv_void_ptr_lt_long=no \
|
||||
logfiledir="/var/log" \
|
||||
runtimedir="/var/run" \
|
||||
EXTRA_LIBS="-ldl -lpthread -lcrypto -lrt -lssl" \
|
||||
)
|
||||
endef
|
||||
|
||||
|
@ -140,7 +147,8 @@ endef
|
|||
define Package/apache/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
# we don't need apxs on the router, it's just for building apache modules.
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{ab,apachectl,checkgid,dbmmanage,envvars,envvars-std,htcacheclean,htdbm,htdigest,htpasswd,httpd,httxt2dbm,logresolve,rotatelogs} $(1)/usr/sbin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{ab,dbmmanage,htdbm,htdigest,htpasswd,httxt2dbm,logresolve} $(1)/usr/sbin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{apachectl,checkgid,envvars,envvars-std,htcacheclean,httpd,rotatelogs} $(1)/usr/sbin/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/httpd.exp $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/share
|
||||
|
|
|
@ -1,5 +1,7 @@
|
|||
Index: httpd-2.4.25/server/test_char.h
|
||||
===================================================================
|
||||
--- /dev/null
|
||||
+++ b/server/test_char.h
|
||||
+++ httpd-2.4.25/server/test_char.h
|
||||
@@ -0,0 +1,23 @@
|
||||
+/* this file is automatically generated by gen_test_char, do not edit */
|
||||
+#define T_ESCAPE_SHELL_CMD (1)
|
||||
|
@ -24,3 +26,24 @@
|
|||
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,
|
||||
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54
|
||||
+};
|
||||
Index: httpd-2.4.25/server/util.c
|
||||
===================================================================
|
||||
--- httpd-2.4.25.orig/server/util.c
|
||||
+++ httpd-2.4.25/server/util.c
|
||||
@@ -96,6 +96,16 @@
|
||||
#undef APLOG_MODULE_INDEX
|
||||
#define APLOG_MODULE_INDEX AP_CORE_MODULE_INDEX
|
||||
|
||||
+#define T_ESCAPE_SHELL_CMD (0x01)
|
||||
+#define T_ESCAPE_PATH_SEGMENT (0x02)
|
||||
+#define T_OS_ESCAPE_PATH (0x04)
|
||||
+#define T_HTTP_TOKEN_STOP (0x08)
|
||||
+#define T_ESCAPE_LOGITEM (0x10)
|
||||
+#define T_ESCAPE_FORENSIC (0x20)
|
||||
+#define T_ESCAPE_URLENCODED (0x40)
|
||||
+#define T_HTTP_CTRLS (0x80)
|
||||
+#define T_VCHAR_OBSTEXT (0x100)
|
||||
+
|
||||
/*
|
||||
* Examine a field value (such as a media-/content-type) string and return
|
||||
* it sans any parameters; e.g., strip off any ';charset=foo' and the like.
|
||||
|
|
|
@ -1,6 +1,8 @@
|
|||
--- a/build/mkconfNW.awk
|
||||
+++ b/build/mkconfNW.awk
|
||||
@@ -24,7 +24,7 @@ BEGIN {
|
||||
Index: httpd-2.4.25/build/mkconfNW.awk
|
||||
===================================================================
|
||||
--- httpd-2.4.25.orig/build/mkconfNW.awk
|
||||
+++ httpd-2.4.25/build/mkconfNW.awk
|
||||
@@ -23,7 +23,7 @@ BEGIN {
|
||||
A["sysconfdir"] = "conf"
|
||||
A["iconsdir"] = "icons"
|
||||
A["manualdir"] = "manual"
|
||||
|
@ -9,8 +11,10 @@
|
|||
A["errordir"] = "error"
|
||||
A["proxycachedir"] = "proxy"
|
||||
|
||||
--- a/config.layout
|
||||
+++ b/config.layout
|
||||
Index: httpd-2.4.25/config.layout
|
||||
===================================================================
|
||||
--- httpd-2.4.25.orig/config.layout
|
||||
+++ httpd-2.4.25/config.layout
|
||||
@@ -28,8 +28,8 @@
|
||||
cgidir: ${datadir}/cgi-bin
|
||||
includedir: ${prefix}/include
|
||||
|
|
|
@ -1,6 +1,8 @@
|
|||
--- a/include/scoreboard.h
|
||||
+++ b/include/scoreboard.h
|
||||
@@ -42,7 +42,7 @@ extern "C" {
|
||||
Index: httpd-2.4.25/include/scoreboard.h
|
||||
===================================================================
|
||||
--- httpd-2.4.25.orig/include/scoreboard.h
|
||||
+++ httpd-2.4.25/include/scoreboard.h
|
||||
@@ -40,7 +40,7 @@ extern "C" {
|
||||
|
||||
/* Scoreboard file, if there is one */
|
||||
#ifndef DEFAULT_SCOREBOARD
|
||||
|
|
|
@ -1,14 +1,16 @@
|
|||
--- a/docs/conf/httpd.conf.in
|
||||
+++ b/docs/conf/httpd.conf.in
|
||||
@@ -52,7 +52,6 @@ Listen @@Port@@
|
||||
Index: httpd-2.4.25/docs/conf/httpd.conf.in
|
||||
===================================================================
|
||||
--- httpd-2.4.25.orig/docs/conf/httpd.conf.in
|
||||
+++ httpd-2.4.25/docs/conf/httpd.conf.in
|
||||
@@ -63,7 +63,6 @@ Listen @@Port@@
|
||||
# Example:
|
||||
# LoadModule foo_module modules/mod_foo.so
|
||||
#
|
||||
-@@LoadModule@@
|
||||
|
||||
<IfModule !mpm_netware_module>
|
||||
<IfModule !mpm_winnt_module>
|
||||
@@ -64,8 +63,8 @@ Listen @@Port@@
|
||||
<IfModule unixd_module>
|
||||
#
|
||||
@@ -74,8 +73,8 @@ Listen @@Port@@
|
||||
# It is usually good practice to create a dedicated user and group for
|
||||
# running httpd, as with most system services.
|
||||
#
|
||||
|
@ -18,8 +20,8 @@
|
|||
+Group nogroup
|
||||
|
||||
</IfModule>
|
||||
</IfModule>
|
||||
@@ -192,7 +191,7 @@ ErrorLog "@rel_logfiledir@/error_log"
|
||||
|
||||
@@ -188,7 +187,7 @@ ErrorLog "@rel_logfiledir@/error_log"
|
||||
# Possible values include: debug, info, notice, warn, error, crit,
|
||||
# alert, emerg.
|
||||
#
|
||||
|
@ -28,7 +30,7 @@
|
|||
|
||||
<IfModule log_config_module>
|
||||
#
|
||||
@@ -337,7 +336,7 @@ DefaultType text/plain
|
||||
@@ -330,7 +329,7 @@ LogLevel warn
|
||||
# contents of the file itself to determine its type. The MIMEMagicFile
|
||||
# directive tells the module where the hint definitions are located.
|
||||
#
|
||||
|
@ -37,16 +39,16 @@
|
|||
|
||||
#
|
||||
# Customizable error responses come in three flavors:
|
||||
@@ -366,7 +365,7 @@ DefaultType text/plain
|
||||
# broken on your system.
|
||||
@@ -360,7 +359,7 @@ LogLevel warn
|
||||
# Defaults: EnableMMAP On, EnableSendfile Off
|
||||
#
|
||||
#EnableMMAP off
|
||||
-#EnableSendfile off
|
||||
-#EnableSendfile on
|
||||
+EnableSendfile off
|
||||
|
||||
# Supplemental configuration
|
||||
#
|
||||
@@ -412,7 +411,7 @@ DefaultType text/plain
|
||||
@@ -411,8 +410,8 @@ Include @rel_sysconfdir@/extra/proxy-htm
|
||||
# starting without SSL on platforms with no /dev/random equivalent
|
||||
# but a statically compiled-in mod_ssl.
|
||||
#
|
||||
|
@ -58,3 +60,4 @@
|
|||
+#SSLRandomSeed startup builtin
|
||||
+#SSLRandomSeed connect builtin
|
||||
+#</IfModule>
|
||||
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- a/support/ab.c
|
||||
+++ b/support/ab.c
|
||||
@@ -2232,8 +2232,10 @@ int main(int argc, const char * const ar
|
||||
} else if (strncasecmp(optarg, "SSL2", 4) == 0) {
|
||||
meth = SSLv2_client_method();
|
||||
#endif
|
||||
+#ifndef OPENSSL_NO_SSL3_METHOD
|
||||
} else if (strncasecmp(optarg, "SSL3", 4) == 0) {
|
||||
meth = SSLv3_client_method();
|
||||
+#endif
|
||||
#ifdef HAVE_TLSV1_X
|
||||
} else if (strncasecmp(optarg, "TLS1.1", 6) == 0) {
|
||||
meth = TLSv1_1_client_method();
|
Loading…
Reference in New Issue