mirror of https://github.com/openwrt/packages.git
squid: update to 6.10
Remove one patch - instead of messing with BUILDCXXFLAGS there we properly define it via CONFIGURE_ARGS inside Makefile of the package. Refresh remaining patch. Signed-off-by: Aleksey Vasilenko <aleksey.vasilenko@gmail.com>pull/24407/head
parent
059a530329
commit
fb4618b805
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=squid
|
||||
PKG_VERSION:=6.9
|
||||
PKG_VERSION:=6.10
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://www2.pl.squid-cache.org/Versions/v6/ \
|
||||
http://www.squid-cache.org/Versions/v6/
|
||||
PKG_HASH:=1ad72d46e1cb556e9561214f0fb181adb87c7c47927ef69bc8acd68a03f61882
|
||||
PKG_HASH:=0b07b187e723f04770dd25beb89aec12030a158696aa8892d87c8b26853408a7
|
||||
|
||||
PKG_MAINTAINER:=Marko Ratkaj <markoratkaj@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
@ -69,6 +69,7 @@ endef
|
|||
|
||||
CONFIGURE_ARGS += \
|
||||
BUILDCXX=$(HOSTCXX_NOCACHE) \
|
||||
BUILDCXXFLAGS="$(HOST_CXXFLAGS) $(HOST_CPPFLAGS) -std=c++17" \
|
||||
--datadir=/usr/share/squid \
|
||||
--libexecdir=/usr/lib/squid \
|
||||
--sysconfdir=/etc/squid \
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -626,7 +626,7 @@ cache_cf.o: cf_parser.cci
|
||||
|
||||
# cf_gen builds the configuration files.
|
||||
cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES) cf_gen_defines.cci
|
||||
- $(BUILDCXX) $(BUILDCXXFLAGS) -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
||||
+ $(BUILDCXX) -std=c++17 -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
||||
|
||||
# squid.conf.default is built by cf_gen when making cf_parser.cci
|
||||
squid.conf.default squid.conf.documented: cf_parser.cci
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1043,7 +1043,7 @@ AC_MSG_NOTICE([HTCP support enabled: $en
|
||||
@@ -1033,7 +1033,7 @@ AC_MSG_NOTICE([HTCP support enabled: $en
|
||||
|
||||
# Cryptograhic libraries
|
||||
SQUID_AUTO_LIB(nettle,[Nettle crypto],[LIBNETTLE])
|
||||
|
|
Loading…
Reference in New Issue