mirror of https://github.com/openwrt/packages.git
redis: update to 6.0.10
Remove uClibc-ng patch as it's not in the tree anymore. Signed-off-by: Rosen Penev <rosenp@gmail.com>pull/14496/head
parent
066f2049ba
commit
fb793f6215
|
@ -1,12 +1,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=redis
|
||||
PKG_VERSION:=6.0.9
|
||||
PKG_VERSION:=6.0.10
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=http://download.redis.io/releases/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=dc2bdcf81c620e9f09cfd12e85d3bc631c897b2db7a55218fd8a65eaa37f86dd
|
||||
PKG_HASH:=79bbb894f9dceb33ca699ee3ca4a4e1228be7fb5547aeb2f99d921e86c1285bd
|
||||
|
||||
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
--- a/src/config.h
|
||||
+++ b/src/config.h
|
||||
@@ -30,6 +30,10 @@
|
||||
#ifndef __CONFIG_H
|
||||
#define __CONFIG_H
|
||||
|
||||
+#if defined(__unix) || defined(__linux__)
|
||||
+#include <features.h>
|
||||
+#endif
|
||||
+
|
||||
#ifdef __APPLE__
|
||||
#include <AvailabilityMacros.h>
|
||||
#endif
|
||||
@@ -63,9 +67,9 @@
|
||||
#endif
|
||||
|
||||
/* Test for backtrace() */
|
||||
-#if defined(__APPLE__) || (defined(__linux__) && defined(__GLIBC__)) || \
|
||||
+#if (defined(__APPLE__) || (defined(__linux__) && defined(__GLIBC__)) || \
|
||||
defined(__FreeBSD__) || ((defined(__OpenBSD__) || defined(__NetBSD__)) && defined(USE_BACKTRACE))\
|
||||
- || defined(__DragonFly__)
|
||||
+ || defined(__DragonFly__)) && !defined(__UCLIBC__)
|
||||
#define HAVE_BACKTRACE 1
|
||||
#endif
|
||||
|
Loading…
Reference in New Issue