mirror of https://github.com/openwrt/packages.git
42 lines
1.4 KiB
Diff
42 lines
1.4 KiB
Diff
From c10b5ed4c6c44e36178b0a5a82da9e8eaa957008 Mon Sep 17 00:00:00 2001
|
|
From: Moritz Warning <moritzwarning@web.de>
|
|
Date: Mon, 6 May 2024 22:34:15 +0200
|
|
Subject: [PATCH 2/5] remove PIE options
|
|
|
|
Signed-off-by: Moritz Warning <moritzwarning@web.de>
|
|
---
|
|
make-linux.mk | 8 ++++----
|
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
--- a/make-linux.mk
|
|
+++ b/make-linux.mk
|
|
@@ -71,7 +71,7 @@ else
|
|
override CFLAGS+=-Wall -Wno-deprecated -pthread $(INCLUDES) -DNDEBUG $(DEFS)
|
|
CXXFLAGS?=-O3 -fstack-protector
|
|
override CXXFLAGS+=-Wall -Wno-deprecated -std=c++17 -pthread $(INCLUDES) -DNDEBUG $(DEFS)
|
|
- LDFLAGS=-pie -Wl,-z,relro,-z,now
|
|
+ LDFLAGS=-Wl,-z,relro,-z,now
|
|
ZT_CARGO_FLAGS=--release
|
|
endif
|
|
|
|
@@ -333,7 +333,7 @@ ifeq ($(ZT_CONTROLLER),1)
|
|
endif
|
|
|
|
# ARM32 hell -- use conservative CFLAGS
|
|
-ifeq ($(ZT_ARCHITECTURE),3)
|
|
+ifeq (0,3)
|
|
ifeq ($(shell if [ -e /usr/bin/dpkg ]; then dpkg --print-architecture; fi),armel)
|
|
override CFLAGS+=-march=armv5t -mfloat-abi=soft -msoft-float -mno-unaligned-access -marm
|
|
override CXXFLAGS+=-march=armv5t -mfloat-abi=soft -msoft-float -mno-unaligned-access -marm
|
|
@@ -360,8 +360,8 @@ ifeq ($(ZT_USE_ARM32_NEON_ASM_CRYPTO),1)
|
|
endif
|
|
|
|
# Position Independence
|
|
-override CFLAGS+=-fPIC -fPIE
|
|
-override CXXFLAGS+=-fPIC -fPIE
|
|
+#override CFLAGS+=-fPIC -fPIE
|
|
+#override CXXFLAGS+=-fPIC -fPIE
|
|
|
|
# Non-executable stack
|
|
override ASFLAGS+=--noexecstack
|